summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-31.0.0.148.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index 986fbd3ee592..5d82caf2c28a 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-31.0.0.122-npapi.i386.tar.gz 8529106 BLAKE2B 71984e263ec5fb1720
DIST adobe-flash-31.0.0.122-npapi.x86_64.tar.gz 9044791 BLAKE2B 4f659381aeffd1a46e8a72cad7612c9b626ff0bf208492502c887a9bcd5beb9888bd8063265a81dd3b848fa97dedde327ab4563b262719fab7620912efe2c1e6 SHA512 c8f27ef630ac6797c0879b444499e954ba5e46564a9d35842134fb963cf7866bbc1badbc773ccdce928c158c716d63d91b79e47b10f8388c97493dd16bd66911
DIST adobe-flash-31.0.0.122-ppapi.i386.tar.gz 8563099 BLAKE2B 0951b14ed7a3c8ea7dbb7ab2de93521435a164a4358f20084cb3e407fb45d19561fd17871553bb2a39da9caf7dec17388d825b51ccafa8184e6fbfd006c328e0 SHA512 fc2efd870a6a2fabd53b1c6d095fd0ffc6c9e1d05a13ebaec93ea31bc84e022e8b54e8c2194a42a54dd3258c8d2fb378fa14205acb3c4a876b07c48e40c18d96
DIST adobe-flash-31.0.0.122-ppapi.x86_64.tar.gz 9482137 BLAKE2B 25585e857de26917880aa09289b7ea2e3b0191f958495d2523461ffd55869a67808c604b9bd5d80c9ea4326df9b72a5a4a3c47a8f2cb32071093df9a7f7ea673 SHA512 64e18f58ce7abda62aa098c47c260226f67d78e17698175629f2777fbcde84b2bd88e80b6247af34bcfe6bed3a558e767b43f45fdf2164cb974d59e70751a4fc
+DIST adobe-flash-31.0.0.148-npapi.i386.tar.gz 8529825 BLAKE2B 3b73bb3f4d1a235f02c6a1819253e9a60489bd388aa00370d7a98d49127f8f666bb99f03a33fbdd9d0ccf12033b38d87d3ecbada13cf3dec185bcc8a988d4a85 SHA512 16dc46da7c71e159845cbd862490fd682ff0c1e97467e42a56ace172fcba07326ed87272f250e9c96b5d3057b08dbb980973567cdc8fe24b0c5463f465056819
+DIST adobe-flash-31.0.0.148-npapi.x86_64.tar.gz 9046263 BLAKE2B 359b08d6bfd3725211bac32fddd28dd18654133c99cdd761879fd48eae1697ab06b6f8d5a22aba98ce44ec484e5fc7b669d13066d0bc90d312aab54fd109edd8 SHA512 79b5a170d63e84d88c74b9ccdbe55a2ec517a28cd69df60eea9c0255ed95d4c0fb8db3a56f7343256b58c4e0aebdb0e421714d92feba494826d06c95f53a54ea
+DIST adobe-flash-31.0.0.148-ppapi.i386.tar.gz 8565088 BLAKE2B b700cc95c8328acbe54b2754afb697dec20287ade78d3b0db687c4dc04c0587c15d6f247a93d74035cb896cc044c28bd85815975b4b5c26399e26e7480d79948 SHA512 695c7df7d224bfd90458980e4e8e12385a12fe6b4586abd1043563a7bc96ae2cc8569ec979c2f6305dd4a99e9373ec1deb210cbf762391122427828b652b3de3
+DIST adobe-flash-31.0.0.148-ppapi.x86_64.tar.gz 9482344 BLAKE2B 4de2c9b9c1580d5badc3b01ec1457d27bb935254b24aa5bbf1cc846a158b8a2f2c08ab7bcd839f9d25cb7ec31be982c1ab9e0fae634855bc6ffbed120cf6442d SHA512 5c0bcd5d2530bc1930d8b2900601b863102a9f22acfcd0a02f29883c43a0e1663d67cfd1065e27a613428829c92c3806824ebc6cf85c83a992755074eed4d82f
diff --git a/www-plugins/adobe-flash/adobe-flash-31.0.0.148.ebuild b/www-plugins/adobe-flash/adobe-flash-31.0.0.148.ebuild
new file mode 100644
index 000000000000..b4fe619358d4
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-31.0.0.148.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}