summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/h2o/h2o-2.2.4.ebuild')
-rw-r--r--www-servers/h2o/h2o-2.2.4.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/www-servers/h2o/h2o-2.2.4.ebuild b/www-servers/h2o/h2o-2.2.4.ebuild
index 25c1690eeeb3..47d1794fa4aa 100644
--- a/www-servers/h2o/h2o-2.2.4.ebuild
+++ b/www-servers/h2o/h2o-2.2.4.ebuild
@@ -3,9 +3,10 @@
EAPI="6"
CMAKE_MAKEFILE_GENERATOR="emake"
+SSL_DEPS_SKIP=1
USE_RUBY="ruby23 ruby24"
-inherit cmake-utils ruby-single systemd toolchain-funcs user
+inherit cmake-utils ruby-single ssl-cert systemd toolchain-funcs user
DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
HOMEPAGE="https://h2o.examp1e.net/"
@@ -88,3 +89,10 @@ src_install() {
fowners ${PN}:${PN} /var/log/${PN}
fperms 0750 /var/log/${PN}
}
+
+pkg_postinst() {
+ if [[ ! -f "${EROOT}"etc/ssl/${PN}/server.key ]]; then
+ install_cert /etc/ssl/${PN}/server
+ chown ${PN}:${PN} "${EROOT}"etc/ssl/${PN}/server.*
+ fi
+}