summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild')
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild28
1 files changed, 3 insertions, 25 deletions
diff --git a/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild b/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild
index 92346204f3c1..e0ae7ed0b2c4 100644
--- a/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild
@@ -12,7 +12,7 @@ USE_RUBY="ruby23 ruby24 ruby25"
PHP_EXT_INI="no"
PHP_EXT_NAME="dummy"
PHP_EXT_OPTIONAL_USE="php"
-USE_PHP="php5-6 php7-1 php7-2 php7-3" # deps must be registered separately below
+USE_PHP="php7-2 php7-3 php7-4" # deps must be registered separately below
MY_P="${P/_/-}"
@@ -42,7 +42,7 @@ UWSGI_PLUGINS_OPT=( alarm_{curl,xmpp} clock_{monotonic,realtime} curl_cron
systemd_logger transformation_toupper tuntap webdav xattr xslt zabbix )
LANG_SUPPORT_SIMPLE=( cgi mono perl ) # plugins which can be built in the main build process
-LANG_SUPPORT_EXTENDED=( go lua php pypy python python_asyncio python_gevent ruby )
+LANG_SUPPORT_EXTENDED=( go lua php python python_asyncio python_gevent ruby )
# plugins to be ignored (for now):
# cheaper_backlog2: example plugin
@@ -67,7 +67,6 @@ REQUIRED_USE="|| ( ${LANG_SUPPORT_SIMPLE[@]} ${LANG_SUPPORT_EXTENDED[@]} )
uwsgi_plugins_emperor_zeromq? ( zeromq )
uwsgi_plugins_forkptyrouter? ( uwsgi_plugins_corerouter )
uwsgi_plugins_router_xmldir? ( xml !expat )
- pypy? ( python_targets_python2_7 )
python? ( ${PYTHON_REQUIRED_USE} )
python_asyncio? ( || ( $(python_gen_useflags -3) ) )
python_gevent? ( python )
@@ -116,12 +115,10 @@ CDEPEND="
mono? ( dev-lang/mono:= )
perl? ( dev-lang/perl:= )
php? (
- php_targets_php5-6? ( dev-lang/php:5.6[embed] )
- php_targets_php7-1? ( dev-lang/php:7.1[embed] )
php_targets_php7-2? ( dev-lang/php:7.2[embed] )
php_targets_php7-3? ( dev-lang/php:7.3[embed] )
+ php_targets_php7-4? ( dev-lang/php:7.4[embed] )
)
- pypy? ( dev-python/pypy )
python? ( ${PYTHON_DEPS} )
python_asyncio? ( virtual/python-greenlet[${PYTHON_USEDEP}] )
python_gevent? ( >=dev-python/gevent-1.3.5[${PYTHON_USEDEP}] )
@@ -245,11 +242,6 @@ python_compile_plugins() {
EPYV=${EPYTHON/.}
PYV=${EPYV/python}
- if [[ ${EPYTHON} == pypy* ]]; then
- einfo "skipping because pypy is not meant to build plugins on its own"
- return
- fi
-
${PYTHON} uwsgiconfig.py --plugin plugins/python gentoo ${EPYV} || die "building plugin for ${EPYTHON} failed"
if use python_asyncio ; then
@@ -265,15 +257,6 @@ python_compile_plugins() {
if use python_gevent || use python_asyncio; then
${PYTHON} uwsgiconfig.py --plugin plugins/greenlet gentoo greenlet${PYV} || die "building plugin for greenlet-support in ${EPYTHON} failed"
fi
-
- if use pypy ; then
- if [[ "${PYV}" == "27" ]] ; then
- # TODO: do some proper patching ? The wiki didn't help... I gave up for now.
- # QA: RWX --- --- usr/lib64/uwsgi/pypy_plugin.so
- append-ldflags -Wl,-z,noexecstack
- ${PYTHON} uwsgiconfig.py --plugin plugins/pypy gentoo pypy || die "building plugin for pypy-support in ${EPYTHON} failed"
- fi
- fi
}
python_install_symlinks() {
@@ -367,11 +350,6 @@ pkg_postinst() {
EPYV=${EPYTHON/.}
PYV=${EPYV/python}
- if [[ ${EPYTHON} == pypy* ]] ; then
- elog " '--plugins pypy' for pypy"
- return
- fi
-
elog " "
elog " '--plugins ${EPYV}' for ${EPYTHON}"
if use python_asyncio ; then