summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/varnish/varnish-4.1.0.ebuild')
-rw-r--r--www-servers/varnish/varnish-4.1.0.ebuild105
1 files changed, 0 insertions, 105 deletions
diff --git a/www-servers/varnish/varnish-4.1.0.ebuild b/www-servers/varnish/varnish-4.1.0.ebuild
deleted file mode 100644
index 24d34d0063ad..000000000000
--- a/www-servers/varnish/varnish-4.1.0.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit user autotools-utils eutils systemd python-r1
-
-DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
-HOMEPAGE="http://www.varnish-cache.org/"
-SRC_URI="http://repo.varnish-cache.org/source/${P}.tar.gz"
-
-LICENSE="BSD-2 GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~mips ~x86"
-IUSE="jemalloc jit static-libs"
-
-CDEPEND="
- || ( dev-libs/libedit sys-libs/readline:= )
- dev-libs/libpcre[jit?]
- jemalloc? ( dev-libs/jemalloc )
- sys-libs/ncurses:="
-
-#varnish compiles stuff at run time
-RDEPEND="
- ${PYTHON_DEPS}
- ${CDEPEND}
- sys-devel/gcc"
-
-DEPEND="
- ${CDEPEND}
- dev-python/docutils
- virtual/pkgconfig"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="test" #315725
-
-DOCS=( README doc/changes.rst )
-
-AUTOTOOLS_AUTORECONF="yes"
-
-pkg_setup() {
- ebegin "Creating varnish user and group"
- enewgroup varnish 40
- enewuser varnish 40 -1 /var/lib/varnish varnish
- eend $?
-}
-
-src_prepare() {
- # Remove bundled libjemalloc. We also fix
- # automagic dep in our patches, bug #461638
- rm -rf lib/libjemalloc
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable jit pcre-jit )
- $(use_with jemalloc)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
-
- newinitd "${FILESDIR}"/varnishlog.initd varnishlog
- newconfd "${FILESDIR}"/varnishlog.confd varnishlog
-
- newinitd "${FILESDIR}"/varnishncsa.initd-r1 varnishncsa
- newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
-
- newinitd "${FILESDIR}"/varnishd.initd-r3 varnishd
- newconfd "${FILESDIR}"/varnishd.confd-r3 varnishd
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
-
- diropts -m750
-
- dodir /var/log/varnish/
-
- systemd_dounit "${FILESDIR}/${PN}d.service"
-
- insinto /etc/varnish/
- doins lib/libvmod_std/vmod.vcc
- doins etc/example.vcl
-
- fowners root:varnish /etc/varnish/
- fowners varnish:varnish /var/lib/varnish/
- fperms 0750 /var/lib/varnish/ /etc/varnish/
-}
-
-pkg_postinst () {
- elog "No demo-/sample-configfile is included in the distribution. Please"
- elog "read the man-page for more info. A sample configuration proxying"
- elog "localhost:8080 for localhost:80 is given in /etc/conf.d/varnishd."
-}