summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/Manifest4
-rw-r--r--x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.7-glibc-2.20.patch61
-rw-r--r--x11-drivers/xf86-input-synaptics/metadata.xml15
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.4.ebuild42
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.8.ebuild42
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.1.ebuild38
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild38
7 files changed, 240 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-synaptics/Manifest b/x11-drivers/xf86-input-synaptics/Manifest
new file mode 100644
index 000000000000..3bbf2d2e9986
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/Manifest
@@ -0,0 +1,4 @@
+DIST xf86-input-synaptics-1.7.4.tar.bz2 451614 SHA256 56a2d2df7bd39e29f56102c62f153e023f3e9b2f5e255309d33fab8e81945af7 SHA512 66db2e51be11e582ba3ea761d5ab65d05278230ddbe7741d7ae58cd844136feb9fc934e1ddc4845bb9961fa5a63743c3e612893d9196b1745140e4105b69220a WHIRLPOOL 914b8fa1db25c0c550368ccdd0e8856b5aefe091e1f29744c6bd350f5156018a6124c75f45517161a91773e54a045d09099c4d9cffa5800fd6e06b025f2822ce
+DIST xf86-input-synaptics-1.7.8.tar.bz2 495292 SHA256 14e7d54f81c2a2503f8acbe5e265dc336a0f2b30d007657d7afbeff979821c11 SHA512 b0f9ec0bd7ff2b7da40e597c331e3c0bffbb8abf2374ddaee5bbac3d1c848cb8a674e9b440c0e41b73916d3e89141d06d0d2ac9cb6ee0a050cba62379c004f50 WHIRLPOOL e02b0c56470b7e464d6516c98009d0953a80b9efe9a35ef2cb1c9a9018fa80952ba30cc9f882268aa64a280103b8953f4b6ee46ea3dd6b1c64467eea67d42fb5
+DIST xf86-input-synaptics-1.8.1.tar.bz2 479212 SHA256 d74fdaf29e9888a2cb494e16d0a9ddb24265c5c765b05392b69c50e84ffbf09a SHA512 15e3250accc5959705aa0cd4e36ed46767860e07ba34561a227b58476df0649739057087d65e9f77d094f766cc06dd9ebd4174abb5efdcc3a04e58031567c178 WHIRLPOOL 3172534dfd193fcc757844cec25ef23a051cd1cf8f4e9dfc31c774cdad170bf32399dd38a00714fcd22b4a776ad1eb0abbf01064f2770a9077e9f560435f12bf
+DIST xf86-input-synaptics-1.8.2.tar.bz2 484261 SHA256 7b0e164ebd02a680e0c695955e783059f37edb0c2656398e0a972adc8e698c80 SHA512 b8880e229437586e9be34aa26f1cfdac20de009caf85a95db39b0232221baf4dee670b2740b1946356fcbfb0bcc2515092daffaab826b3460698c28b48e20a12 WHIRLPOOL 9cbc809e5386c4d65394b5bcc8b3f569a0b754e04f9738a6ada3e7753ef9f8cfee81fddc62de15a99e36410116be935207e5947cd7bf969d2215b8e979d02e77
diff --git a/x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.7-glibc-2.20.patch b/x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.7-glibc-2.20.patch
new file mode 100644
index 000000000000..a599d8db4ccc
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.7-glibc-2.20.patch
@@ -0,0 +1,61 @@
+From 96e60a4ea242d2decf109835981ae186cc36f642 Mon Sep 17 00:00:00 2001
+From: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Fri, 29 Aug 2014 07:57:41 +1000
+Subject: Include xorg-server.h to fix build errors on newest glibc
+
+In file included from /usr/include/string.h:634:0,
+ from /usr/include/xorg/os.h:53,
+ from /usr/include/xorg/misc.h:115,
+ from /usr/include/xorg/xf86str.h:37,
+ from /usr/include/xorg/xf86Xinput.h:54,
+ from synproto.h:36,
+ from synproto.c:24:
+/usr/include/xorg/os.h:579:1: error: expected identifier or '(' before '__extension__'
+ strndup(const char *str, size_t n);
+
+See http://lists.freedesktop.org/archives/xorg-devel/2014-July/043070.html
+
+Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+
+diff --git a/src/eventcomm.h b/src/eventcomm.h
+index 4d759ff..e0f8743 100644
+--- a/src/eventcomm.h
++++ b/src/eventcomm.h
+@@ -27,6 +27,8 @@
+ #ifndef _EVENTCOMM_H_
+ #define _EVENTCOMM_H_
+
++#include <xorg-server.h>
++
+ #include <linux/input.h>
+ #include <linux/version.h>
+ #include <xf86Xinput.h>
+diff --git a/src/ps2comm.h b/src/ps2comm.h
+index 2be55e4..fa71d10 100644
+--- a/src/ps2comm.h
++++ b/src/ps2comm.h
+@@ -22,6 +22,8 @@
+ #ifndef _PS2COMM_H_
+ #define _PS2COMM_H_
+
++#include <xorg-server.h>
++
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+ #include "xf86_OSproc.h"
+diff --git a/src/synproto.h b/src/synproto.h
+index c52838c..6ba6740 100644
+--- a/src/synproto.h
++++ b/src/synproto.h
+@@ -31,6 +31,8 @@
+ #include "config.h"
+ #endif
+
++#include <xorg-server.h>
++
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+ #include <xf86Xinput.h>
+--
+cgit v0.10.2
+
diff --git a/x11-drivers/xf86-input-synaptics/metadata.xml b/x11-drivers/xf86-input-synaptics/metadata.xml
new file mode 100644
index 000000000000..c923f3ff7c16
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>x11</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+ </maintainer>
+ <maintainer>
+ <email>egore@gmx.de</email>
+ <name>Christoph Brill</name>
+ <description>upstream co-maintainer</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.4.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.4.ebuild
new file mode 100644
index 000000000000..b745fcab1872
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/mtdev
+ >=x11-base/xorg-server-1.12
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ >=x11-proto/inputproto-2.1.99.3
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7-glibc-2.20.patch
+)
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.8.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.8.ebuild
new file mode 100644
index 000000000000..21f5f57e9d76
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.7.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/mtdev
+ >=x11-base/xorg-server-1.12
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ >=x11-proto/inputproto-2.1.99.3
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7-glibc-2.20.patch
+)
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.1.ebuild
new file mode 100644
index 000000000000..5d896923c970
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
+IUSE="kernel_linux"
+
+RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
+ >=x11-base/xorg-server-1.14
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ >=x11-proto/inputproto-2.1.99.3
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild
new file mode 100644
index 000000000000..215fd1050aa1
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux"
+
+RDEPEND="kernel_linux? ( >=dev-libs/libevdev-0.4 )
+ >=x11-base/xorg-server-1.14
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.37
+ >=x11-proto/inputproto-2.1.99.3
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}