summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-dummy')
-rw-r--r--x11-drivers/xf86-video-dummy/Manifest2
-rw-r--r--x11-drivers/xf86-video-dummy/metadata.xml5
-rw-r--r--x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.6.ebuild24
-rw-r--r--x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.7.ebuild24
4 files changed, 55 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-dummy/Manifest b/x11-drivers/xf86-video-dummy/Manifest
new file mode 100644
index 000000000000..9ac79f47954c
--- /dev/null
+++ b/x11-drivers/xf86-video-dummy/Manifest
@@ -0,0 +1,2 @@
+DIST xf86-video-dummy-0.3.6.tar.bz2 285892 SHA256 44335b640126d339700256dae731bd5af79afd027da172bad8a991a33a1de798 SHA512 3a530083d591ebde37b58a329d9a6ed4955d09d8f3f7fb566840681f2588aa752014c8753f411aec0410a2704b3b55729868a27aee138df42eb7d7bb5a5a52c5 WHIRLPOOL 4475426b4469968ad63f830a66cc44452f39194c0abcaf9b54e527fe8c560f6dc7b38030a5f1dd95ecec9e82f291bcb3bde3820c1506f2bcdce60d1e352e6ec4
+DIST xf86-video-dummy-0.3.7.tar.bz2 279806 SHA256 56f84fcbc515685529ad8e10bca1072731d9c096b97c5d35ddc95cd589b98680 SHA512 2893964f19901af0b18417a271a3418c5adfaa311cd1688c159b86a7bdf68517d53d98a9b2c1a9942c7d2cde8ccb742832fd78c2ab0aa29844d261b9334548ec WHIRLPOOL 7c028fdd13ee0194cedecc7ca1409254b5cfc3f1766c50f87cbd36e9d8e705e603c4cb7d02980b2ad6f35774686560690441b292206ec637bcbe3e9237196315
diff --git a/x11-drivers/xf86-video-dummy/metadata.xml b/x11-drivers/xf86-video-dummy/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-drivers/xf86-video-dummy/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.6.ebuild b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.6.ebuild
new file mode 100644
index 000000000000..5552b569a23f
--- /dev/null
+++ b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit xorg-2
+
+DESCRIPTION="X.Org driver for dummy cards"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dga"
+
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ dga? (
+ x11-proto/xf86dgaproto
+ )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dga)
+ )
+ xorg-2_pkg_setup
+}
diff --git a/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.7.ebuild b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.7.ebuild
new file mode 100644
index 000000000000..ddbb5c625ff6
--- /dev/null
+++ b/x11-drivers/xf86-video-dummy/xf86-video-dummy-0.3.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xorg-2
+
+DESCRIPTION="X.Org driver for dummy cards"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="dga"
+
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ dga? (
+ x11-proto/xf86dgaproto
+ )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dga)
+ )
+ xorg-2_pkg_setup
+}