summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/Manifest5
-rw-r--r--x11-libs/fox/files/fox-1.6.40-libpng15.patch32
-rw-r--r--x11-libs/fox/files/jpeg-9.patch40
-rw-r--r--x11-libs/fox/fox-1.6.45.ebuild42
-rw-r--r--x11-libs/fox/fox-1.6.49.ebuild42
-rw-r--r--x11-libs/fox/fox-1.7.45.ebuild55
-rw-r--r--x11-libs/fox/fox-1.7.47.ebuild55
-rw-r--r--x11-libs/fox/fox-1.7.49.ebuild60
-rw-r--r--x11-libs/fox/metadata.xml8
9 files changed, 339 insertions, 0 deletions
diff --git a/x11-libs/fox/Manifest b/x11-libs/fox/Manifest
new file mode 100644
index 000000000000..23bec2f5beeb
--- /dev/null
+++ b/x11-libs/fox/Manifest
@@ -0,0 +1,5 @@
+DIST fox-1.6.45.tar.gz 4372554 SHA256 ec2ec7042c3198f78adea25b8958027955af4e3f8371733d1ff43fe5289bc4d6 SHA512 a5fbe6b27ac8bf2b0419e670f80dec2ae39c25988193d3910b62612776e932f8a3289694a2032124394cc367415aa2e6a8820b83a61a78f6bc78b4749f0b2e72 WHIRLPOOL f447cbb19efd3d3bc2b54d4c43f5d4f03884c2b272f27a71304c0360b4a30b4f393947e8c826c1bb5e88a8b039294fbf9e5d54b33dbb184dc9815a3944e3b48a
+DIST fox-1.6.49.tar.gz 4383152 SHA256 3679ecd23064958259fbef5898aabb048d63b2dcb796de1d8801fe0b51e5a90e SHA512 cd7dd5fd26bcdde6ed69d547e2b08582f0e88b66b6f1bac9b5cd2279b543edbf5b9a63cc2ed05f1a1fd7e7309ede96404cf7a5d2d8eb8763dc0fb41d613b0ee8 WHIRLPOOL 1592d2560a7967c491dcfeda40e66a45d2811424e222c5f1e768b28c8ce147d7815f46d22006ac9809b967d0c825b7828aad206ab55bcb80cae064f646fd3608
+DIST fox-1.7.45.tar.gz 5254563 SHA256 78f2b5f609a52d21da08e693d45b8eeb9d4ceed52ad86e451ef4485f2375c829 SHA512 ec8acf0eb0b1882254f7df2abdcb87445992fc9fb8165afcc08b8dd52a718cb31953849efc7a530bd682e6265687bdf4dc9fb5c930557b9405235182894684b0 WHIRLPOOL 08808e67e0e31c7389b1d4ac097d7d707fb48a925df233021913bc80363002c0c4ce19c8630f4bd5c87ebb5bc5c010dc7f3260f415dfa5b60390c5aae316de78
+DIST fox-1.7.47.tar.gz 5271135 SHA256 7f1de8566b88b0010137ea1172168d53494d2d14bfa03fe32f7796146a31a2a3 SHA512 8802c7a21ba35b48a638fb87354da3de54c82ebdd3f931a601f55473fe1f7c16bfa2df253e8531af2058665d9b6f31adf52f6973c2d94f435cc90ac112af22ed WHIRLPOOL fbcf4540b268e95fa4d70ed335d8f499ec46e18390cdc090c98c21b4be5ff3ec576439265cfcf8b90c037fed7937c3a5f19f8544db1906cf86a3f255b8092d62
+DIST fox-1.7.49.tar.gz 5336321 SHA256 2435c56cde3ba6617c638af4f3bac39e8f4d5dd5a5c6d0805d274c7ba05c520c SHA512 da6c3478370f1e72091675e49f8458a6722eca4735bf89052b2b7ef02f4e74ee41f10c9fcc39a24a1571dd0bb1cdf779e9dea5bf15be20722ca783c9d59eb6e9 WHIRLPOOL 53ad3d34e57507702fc2ac9bd7b446021a99e3dff5b337cda090a670b06d4733abce2bbca88a7586e8af2d00f16ee84b0bd3c42f66fd6e430cc6d342bb76b1ff
diff --git a/x11-libs/fox/files/fox-1.6.40-libpng15.patch b/x11-libs/fox/files/fox-1.6.40-libpng15.patch
new file mode 100644
index 000000000000..2411226694de
--- /dev/null
+++ b/x11-libs/fox/files/fox-1.6.40-libpng15.patch
@@ -0,0 +1,32 @@
+--- src/fxpngio.cpp
++++ src/fxpngio.cpp
+@@ -75,7 +75,11 @@
+ static void user_error_fn(png_structp png_ptr,png_const_charp){
+ FXStream* store=(FXStream*)png_get_error_ptr(png_ptr);
+ store->setError(FXStreamFormat); // Flag this as a format error in FXStream
++#if (PNG_LIBPNG_VER < 10500)
+ longjmp(png_ptr->jmpbuf,1); // Bail out
++#else
++ png_longjmp(png_ptr,1); // Bail out
++#endif
+ }
+
+
+@@ -118,7 +122,7 @@
+ }
+
+ // Set error handling
+- if(setjmp(png_ptr->jmpbuf)){
++ if(setjmp(png_jmpbuf(png_ptr))){
+
+ // Free all of the memory associated with the png_ptr and info_ptr
+ png_destroy_read_struct(&png_ptr,&info_ptr,(png_infopp)NULL);
+@@ -231,7 +235,7 @@
+ }
+
+ // Set error handling.
+- if(setjmp(png_ptr->jmpbuf)){
++ if(setjmp(png_jmpbuf(png_ptr))){
+ png_destroy_write_struct(&png_ptr,&info_ptr);
+ return false;
+ }
diff --git a/x11-libs/fox/files/jpeg-9.patch b/x11-libs/fox/files/jpeg-9.patch
new file mode 100644
index 000000000000..8075f03251c1
--- /dev/null
+++ b/x11-libs/fox/files/jpeg-9.patch
@@ -0,0 +1,40 @@
+--- a/lib/fxjpegio.cpp
++++ b/lib/fxjpegio.cpp
+@@ -138,7 +138,7 @@
+ src->pub.next_input_byte=src->buffer;
+ src->pub.bytes_in_buffer=1;
+ }
+- return true;
++ return TRUE;
+ }
+
+
+@@ -216,7 +216,7 @@
+ srcinfo.src=&src.pub;
+
+ // read the header from the jpg;
+- jpeg_read_header(&srcinfo,true);
++ jpeg_read_header(&srcinfo,TRUE);
+
+ // make sure the output is RGB
+ srcinfo.out_color_space=JCS_RGB;
+@@ -279,7 +279,7 @@
+ dest->stream->save(dest->buffer,JPEG_BUFFER_SIZE);
+ dest->pub.free_in_buffer=JPEG_BUFFER_SIZE;
+ dest->pub.next_output_byte=dest->buffer;
+- return true;
++ return TRUE;
+ }
+
+
+@@ -336,8 +336,8 @@
+ dstinfo.dest=&dst.pub;
+
+ jpeg_set_defaults(&dstinfo);
+- jpeg_set_quality(&dstinfo,quality,true);
+- jpeg_start_compress(&dstinfo,true);
++ jpeg_set_quality(&dstinfo,quality,TRUE);
++ jpeg_start_compress(&dstinfo,TRUE);
+
+ // Write the jpeg data
+ pp=data;
diff --git a/x11-libs/fox/fox-1.6.45.ebuild b/x11-libs/fox/fox-1.6.45.ebuild
new file mode 100644
index 000000000000..f587f59412f6
--- /dev/null
+++ b/x11-libs/fox/fox-1.6.45.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ jpeg? ( virtual/jpeg )
+ opengl? ( virtual/glu virtual/opengl )
+ png? ( >=media-libs/libpng-1.2.5 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ truetype? ( =media-libs/freetype-2*
+ x11-libs/libXft )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_prepare() {
+ sed -i -e 's/-lXft/-lXft -lfontconfig/' "${S}/configure.ac"
+ fox_src_prepare
+}
+
+src_configure() {
+ FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)" fox_src_configure
+}
diff --git a/x11-libs/fox/fox-1.6.49.ebuild b/x11-libs/fox/fox-1.6.49.ebuild
new file mode 100644
index 000000000000..a55818f29015
--- /dev/null
+++ b/x11-libs/fox/fox-1.6.49.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ jpeg? ( virtual/jpeg )
+ opengl? ( virtual/glu virtual/opengl )
+ png? ( >=media-libs/libpng-1.2.5 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ truetype? ( =media-libs/freetype-2*
+ x11-libs/libXft )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_prepare() {
+ sed -i -e 's/-lXft/-lXft -lfontconfig/' "${S}/configure.ac"
+ fox_src_prepare
+}
+
+src_configure() {
+ FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)" fox_src_configure
+}
diff --git a/x11-libs/fox/fox-1.7.45.ebuild b/x11-libs/fox/fox-1.7.45.ebuild
new file mode 100644
index 000000000000..af94a5fda255
--- /dev/null
+++ b/x11-libs/fox/fox-1.7.45.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+
+# newish autoconf needed for working mmap check
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ >=sys-devel/autoconf-2.67
+ bzip2? ( app-arch/bzip2 )
+ jpeg? ( virtual/jpeg )
+ opengl? ( virtual/glu virtual/opengl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype:2
+ x11-libs/libXft )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_configure() {
+ FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)" fox_src_configure
+}
+
+src_install() {
+ fox_src_install
+ CP="${ED}/usr/bin/ControlPanel"
+ if [[ -f ${CP} ]] ; then
+ mv "${CP}" "${ED}/usr/bin/fox-ControlPanel-${SLOT}" || \
+ die "Failed to install ControlPanel"
+ fi
+}
+
+pkg_postinst() {
+ fox_pkg_postinst
+
+ einfo "ControlPanel has been installed to 'fox-ControlPanel-${SLOT}' to avoid conflicts"
+ einfo "with other packages."
+}
diff --git a/x11-libs/fox/fox-1.7.47.ebuild b/x11-libs/fox/fox-1.7.47.ebuild
new file mode 100644
index 000000000000..af94a5fda255
--- /dev/null
+++ b/x11-libs/fox/fox-1.7.47.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+
+# newish autoconf needed for working mmap check
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ >=sys-devel/autoconf-2.67
+ bzip2? ( app-arch/bzip2 )
+ jpeg? ( virtual/jpeg )
+ opengl? ( virtual/glu virtual/opengl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype:2
+ x11-libs/libXft )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_configure() {
+ FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)" fox_src_configure
+}
+
+src_install() {
+ fox_src_install
+ CP="${ED}/usr/bin/ControlPanel"
+ if [[ -f ${CP} ]] ; then
+ mv "${CP}" "${ED}/usr/bin/fox-ControlPanel-${SLOT}" || \
+ die "Failed to install ControlPanel"
+ fi
+}
+
+pkg_postinst() {
+ fox_pkg_postinst
+
+ einfo "ControlPanel has been installed to 'fox-ControlPanel-${SLOT}' to avoid conflicts"
+ einfo "with other packages."
+}
diff --git a/x11-libs/fox/fox-1.7.49.ebuild b/x11-libs/fox/fox-1.7.49.ebuild
new file mode 100644
index 000000000000..ca5d2ae536b8
--- /dev/null
+++ b/x11-libs/fox/fox-1.7.49.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.7"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~ppc64 ~sparc x86"
+IUSE="+bzip2 +jpeg +opengl +png tiff +truetype +zlib"
+
+# newish autoconf needed for working mmap check
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ >=sys-devel/autoconf-2.67
+ bzip2? ( app-arch/bzip2 )
+ jpeg? ( virtual/jpeg )
+ opengl? ( virtual/glu virtual/opengl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+ truetype? ( media-libs/freetype:2
+ x11-libs/libXft )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_prepare() {
+ fox_src_prepare
+ epatch "${FILESDIR}/jpeg-9.patch"
+}
+
+src_configure() {
+ FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)" fox_src_configure
+}
+
+src_install() {
+ fox_src_install
+ CP="${ED}/usr/bin/ControlPanel"
+ if [[ -f ${CP} ]] ; then
+ mv "${CP}" "${ED}/usr/bin/fox-ControlPanel-${SLOT}" || \
+ die "Failed to install ControlPanel"
+ fi
+}
+
+pkg_postinst() {
+ fox_pkg_postinst
+
+ einfo "ControlPanel has been installed to 'fox-ControlPanel-${SLOT}' to avoid conflicts"
+ einfo "with other packages."
+}
diff --git a/x11-libs/fox/metadata.xml b/x11-libs/fox/metadata.xml
new file mode 100644
index 000000000000..2d6f81e625c6
--- /dev/null
+++ b/x11-libs/fox/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mabi@gentoo.org</email>
+ <name>Matti Bickel</name>
+</maintainer>
+</pkgmetadata>