summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/gnome-pty-helper')
-rw-r--r--x11-libs/gnome-pty-helper/Manifest3
-rw-r--r--x11-libs/gnome-pty-helper/gnome-pty-helper-0.36.3.ebuild33
-rw-r--r--x11-libs/gnome-pty-helper/gnome-pty-helper-0.38.3.ebuild33
-rw-r--r--x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild33
-rw-r--r--x11-libs/gnome-pty-helper/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/x11-libs/gnome-pty-helper/Manifest b/x11-libs/gnome-pty-helper/Manifest
new file mode 100644
index 000000000000..f27472b7ed8b
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/Manifest
@@ -0,0 +1,3 @@
+DIST vte-0.36.3.tar.xz 1013412 SHA256 54e5b07be3c0f7b158302f54ee79d4de1cb002f4259b6642b79b1e0e314a959c SHA512 9e0c4e60c5a271720d7b480c9618069752faec6c310cc2477e67cdb1c3e961f6981d39c9116716739390dc8e4bab9bf06cf6c5d7d2546062e48523f85d731c77 WHIRLPOOL 0c582f50a07b9a55e8e7b16ae371b913348e8f93fc50ff734ea04a481a5e1ca30ebf3c3781dcd20fd340f50b34cd8f516de76ca59093f3952f23b99a5b30ddca
+DIST vte-0.38.3.tar.xz 1005548 SHA256 3f3ae063207ceea9ca2abd1cf9c9f8bd2b66ca82156609f31f3554288c0c2bf4 SHA512 f8a28be524dcd4a6a5dbdd83655eaea0e41ce20e642130c1db8a1bbb29b71ff2421972cb630322a6e443a4aae21e2cc9350d7b06264bf3a1b7b7f793d3818164 WHIRLPOOL 4f67b4f6060b4178d8dde717577ae534fe68f436ce6d3f10e914c40bad44ce01c48f135c600b3d85c4f78a6577af0652bffa0b7e877ff2dc22b9996c9da00d76
+DIST vte-0.40.2.tar.xz 923852 SHA256 9b68fbc16b27f2d79e6271f2b0708808594ac5acf979d0fccea118608199fd2d SHA512 06d1c9a34e8e82e1bd54810d245d908ebb837538ba19fbaabe683cdf3b96b7cb1630516ddeabf18b0294922b8d98d2b9a2f5028c171fac2ad913974d94555eb2 WHIRLPOOL 2499e01c2b0d38645b61d4c0a1814d7a3196df6d300577380f1e622c06a974a4cd0d9799fff35f1b0680603aa3a0be38730991ace83df90bfb265009873c5858
diff --git a/x11-libs/gnome-pty-helper/gnome-pty-helper-0.36.3.ebuild b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.36.3.ebuild
new file mode 100644
index 000000000000..e3d2c44652c0
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.36.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_ORG_MODULE="vte"
+
+inherit gnome2
+
+DESCRIPTION="GNOME Setuid helper for opening ptys"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+# gnome-pty-helper is inside vte
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+hardened"
+
+# gnome-pty-helper was spit out with 0.27.90
+RDEPEND="!<x11-libs/vte-0.27.90"
+DEPEND=""
+
+S="${WORKDIR}/vte-${PV}/gnome-pty-helper"
+
+src_prepare() {
+ # As recommended by upstream (/usr/libexec/$PN is a setgid binary)
+ if use hardened; then
+ export SUID_CFLAGS="-fPIE ${SUID_CFLAGS}"
+ export SUID_LDFLAGS="-pie ${SUID_LDFLAGS}"
+ fi
+ gnome2_src_prepare
+}
diff --git a/x11-libs/gnome-pty-helper/gnome-pty-helper-0.38.3.ebuild b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.38.3.ebuild
new file mode 100644
index 000000000000..49ecda521c6b
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.38.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_ORG_MODULE="vte"
+
+inherit gnome2
+
+DESCRIPTION="GNOME Setuid helper for opening ptys"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+# gnome-pty-helper is inside vte
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+hardened"
+
+# gnome-pty-helper was spit out with 0.27.90
+RDEPEND="!<x11-libs/vte-0.27.90"
+DEPEND=""
+
+S="${WORKDIR}/vte-${PV}/gnome-pty-helper"
+
+src_prepare() {
+ # As recommended by upstream (/usr/libexec/$PN is a setgid binary)
+ if use hardened; then
+ export SUID_CFLAGS="-fPIE ${SUID_CFLAGS}"
+ export SUID_LDFLAGS="-pie ${SUID_LDFLAGS}"
+ fi
+ gnome2_src_prepare
+}
diff --git a/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild
new file mode 100644
index 000000000000..890ad6f4c9eb
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/gnome-pty-helper-0.40.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_ORG_MODULE="vte"
+
+inherit gnome2
+
+DESCRIPTION="GNOME Setuid helper for opening ptys"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+# gnome-pty-helper is inside vte
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+hardened"
+
+# gnome-pty-helper was spit out with 0.27.90
+RDEPEND="!<x11-libs/vte-0.27.90"
+DEPEND=""
+
+S="${WORKDIR}/vte-${PV}/gnome-pty-helper"
+
+src_prepare() {
+ # As recommended by upstream (/usr/libexec/$PN is a setgid binary)
+ if use hardened; then
+ export SUID_CFLAGS="-fPIE ${SUID_CFLAGS}"
+ export SUID_LDFLAGS="-pie ${SUID_LDFLAGS}"
+ fi
+ gnome2_src_prepare
+}
diff --git a/x11-libs/gnome-pty-helper/metadata.xml b/x11-libs/gnome-pty-helper/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/x11-libs/gnome-pty-helper/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>