summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/goffice')
-rw-r--r--x11-libs/goffice/Manifest3
-rw-r--r--x11-libs/goffice/files/goffice-0.8.17-no-pcre.patch219
-rw-r--r--x11-libs/goffice/goffice-0.10.21.ebuild56
-rw-r--r--x11-libs/goffice/goffice-0.10.22.ebuild56
-rw-r--r--x11-libs/goffice/goffice-0.8.17-r1.ebuild62
-rw-r--r--x11-libs/goffice/metadata.xml10
6 files changed, 406 insertions, 0 deletions
diff --git a/x11-libs/goffice/Manifest b/x11-libs/goffice/Manifest
new file mode 100644
index 000000000000..8140979b7781
--- /dev/null
+++ b/x11-libs/goffice/Manifest
@@ -0,0 +1,3 @@
+DIST goffice-0.10.21.tar.xz 2336136 SHA256 be3cd0f31bb304369283fd13b441aa67705e62231db2001da191c49f724749c2 SHA512 e2363b84c9fac4a46860401e3bba3a92bc527bd0f40d593309788bd4a02bfe7cc55f49bb0587639435563b02e9729ee592069a4120482f2194eeb2c59512912f WHIRLPOOL f45ce739effe3df1f19f54f1673f0faba676b566c6677372c33a9df643422318e45463e9b85a5f9a944c7baeda4c228ba0aa8f40ff6d1a8d4c6d6ff064af0987
+DIST goffice-0.10.22.tar.xz 2347728 SHA256 0206a87a323b52a874dc54491374245f9e1c5f62e93a2ce4a02fb444a26b0e28 SHA512 e9a8a6177d3f8ac866c7e9b508ca6a92bb9ab7eec00d4472b9ad31c4c54c1e337a8b21e23dd668f1adc8d5dd0c3df8f1f115fc7c10ffda31993c262b7eccb514 WHIRLPOOL c2c9e45391e1ae5d68c48462fc361be39a6def78bbd60f111fb1d96358794332e6d9490ea220a13d7b6df213d9ca00b9335b4fa8ed79ee496f9bbafc85fcc983
+DIST goffice-0.8.17.tar.xz 1814488 SHA256 165070beb67b84580afe80a8a100b674a81d553ab791acd72ac0c655f4fadb15 SHA512 61a3063d37e2ded4d4065d261f728c862daea04090ac38abe2524089ed1ee253e0d77e501f5b3451b1e011491a8225f90fd4914f28ce2a347ecf561098e6400c WHIRLPOOL 12ac2587af25c41686797b9bd5ff93429687217cb3d14e130067685701fd0685ed1c4f9900eb34a15cfb30dcdfe9ebe9f9856a1b4eb6684555d0a9cb1ef86ff1
diff --git a/x11-libs/goffice/files/goffice-0.8.17-no-pcre.patch b/x11-libs/goffice/files/goffice-0.8.17-no-pcre.patch
new file mode 100644
index 000000000000..4691acdcd8ff
--- /dev/null
+++ b/x11-libs/goffice/files/goffice-0.8.17-no-pcre.patch
@@ -0,0 +1,219 @@
+From 00b816027e11f5fd890df07ae94d720cce106f34 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Fri, 20 Apr 2012 14:57:59 -0400
+Subject: [PATCH] Drop pcre workaround for <glib-2.15.1
+
+For unknown reason, it sometimes gets enabled even on modern systems,
+causing problems.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=670316
+---
+ configure.in | 24 +----------
+ goffice/utils/regutf8.c | 106 -----------------------------------------------
+ 2 files changed, 1 insertions(+), 129 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index fd40d53..62e299d 100644
+--- a/configure.in
++++ b/configure.in
+@@ -93,7 +93,7 @@ PKG_PROG_PKG_CONFIG
+
+ dnl *****************************
+ goffice_reqs="
+- glib-2.0 >= 2.8.0
++ glib-2.0 >= 2.16.0
+ gobject-2.0 >= 2.16.0
+ gmodule-2.0 >= 2.16.0
+ gio-2.0 >= 2.16.0
+@@ -492,13 +492,6 @@ SAVE_CFLAGS=$CFLAGS
+ SAVE_LIBS=$LIBS
+ CFLAGS="$CFLAGS $GOFFICE_CFLAGS"
+ LIBS="$GOFFICE_LIBS $LIBS"
+-AC_MSG_CHECKING([for G_REGEX_ERROR_STRAY_BACKSLASH])
+-AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <glib/gregex.h>]], [[GRegexError error=G_REGEX_ERROR_STRAY_BACKSLASH;]])],
+- [AC_DEFINE(HAVE_G_REGEX_ERROR_STRAY_BACKSLASH, 1, [Define if G_REGEX_ERROR_STRAY_BACKSLASH is defined])
+- glib_has_G_REGEX_ERROR_STRAY_BACKSLASH=yes
+- AC_MSG_RESULT(yes)],
+- [AC_MSG_RESULT(no)
+- glib_has_G_REGEX_ERROR_STRAY_BACKSLASH=no])
+ if test "x$goffice_with_gtk" = "xtrue" ; then
+ AC_CHECK_FUNCS(gtk_dialog_get_response_for_widget)
+ AC_CHECK_FUNCS(gtk_widget_set_tooltip_text gtk_tool_item_set_tooltip_text,
+@@ -511,21 +504,6 @@ if test $gtk_disable_deprecated = yes; then
+ CFLAGS="$CFLAGS -DGTK_DISABLE_DEPRECATED"
+ fi
+
+-if test "x$glib_has_G_REGEX_ERROR_STRAY_BACKSLASH" = "xno"; then
+- dnl Check for working pcre
+- AC_CHECK_HEADER(pcre.h,[], AC_MSG_ERROR([Header files for PCRE were not found]))
+- AC_CHECK_LIB(pcre,pcre_compile2,[], AC_MSG_ERROR([The PCRE library is missing or too old]))
+- AC_MSG_CHECKING([for UTF-8 support in pcre])
+- if (pcretest -C 2>&1) | grep -i "^ *UTF-8 support" >/dev/null; then
+- AC_MSG_RESULT(yes)
+- LIBS="$LIBS -lpcre"
+- EXTRA_LIBS="$EXTRA_LIBS -lpcre"
+- else
+- AC_MSG_ERROR([The installed PCRE library is not configured for UTF-8 support.])
+- fi
+-fi
+-
+-
+ AC_DEFUN([GOFFICE_CHECK_FUNC],
+ [AC_CHECK_FUNC([$1],
+ [],
+diff --git a/goffice/utils/regutf8.c b/goffice/utils/regutf8.c
+index bc4aae4..3f32dd6 100644
+--- a/goffice/utils/regutf8.c
++++ b/goffice/utils/regutf8.c
+@@ -7,9 +7,6 @@
+
+ #include <goffice/goffice-config.h>
+ #include "regutf8.h"
+-#ifndef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
+-#include <pcre.h>
+-#endif
+ #include "go-glib-extras.h"
+ #include <gsf/gsf-impl-utils.h>
+ #include <glib/gi18n-lib.h>
+@@ -21,11 +18,7 @@ void
+ go_regfree (GORegexp *gor)
+ {
+ if (gor->ppcre) {
+-#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
+ g_regex_unref (gor->ppcre);
+-#else
+- pcre_free (gor->ppcre);
+-#endif
+ gor->ppcre = NULL;
+ }
+ }
+@@ -70,7 +63,6 @@ go_regerror (int errcode, const GORegexp *gor, char *dst, size_t dstsize)
+ int
+ go_regcomp (GORegexp *gor, const char *pat, int cflags)
+ {
+-#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
+ GError *error = NULL;
+ GRegex *r;
+ int coptions =
+@@ -119,47 +111,6 @@ go_regcomp (GORegexp *gor, const char *pat, int cflags)
+ gor->nosub = (cflags & GO_REG_NOSUB) != 0;
+ return 0;
+ }
+-#else
+- const char *errorptr;
+- int errorofs, errorcode;
+- pcre *r;
+- int coptions =
+- PCRE_UTF8 |
+- PCRE_NO_UTF8_CHECK |
+- ((cflags & GO_REG_ICASE) ? PCRE_CASELESS : 0) |
+- ((cflags & GO_REG_NEWLINE) ? PCRE_MULTILINE : 0);
+-
+- if (&pcre_compile2 == NULL) {
+- g_error ("libgoffice has been dynamically linked against a libpcre\n"
+- "that lacks the pcre_compile2 function. This indicates a\n"
+- "distribution dependency problem. Please report this at\n"
+- "bugzilla.gnome.org and for you distribution.");
+- }
+-
+- gor->ppcre = r = pcre_compile2 (pat, coptions,
+- &errorcode, &errorptr, &errorofs,
+- NULL);
+-
+- if (r == NULL) {
+- switch (errorcode) {
+- case 1: case 2: case 3: case 37: return GO_REG_EESCAPE;
+- case 4: case 5: return GO_REG_EBRACE;
+- case 6: return GO_REG_EBRACK;
+- case 7: case 30: return GO_REG_ECTYPE;
+- case 8: return GO_REG_ERANGE;
+- case 9: case 10: return GO_REG_BADRPT;
+- case 14: case 18: case 22: return GO_REG_EPAREN;
+- case 15: return GO_REG_ESUBREG;
+- case 19: case 20: return GO_REG_ESIZE;
+- case 21: return GO_REG_ESPACE;
+- default: return GO_REG_BADPAT;
+- }
+- } else {
+- gor->re_nsub = pcre_info (r, NULL, NULL);
+- gor->nosub = (cflags & GO_REG_NOSUB) != 0;
+- return 0;
+- }
+-#endif
+ return 0;
+ }
+
+@@ -167,7 +118,6 @@ int
+ go_regexec (const GORegexp *gor, const char *txt,
+ size_t nmatch, GORegmatch *pmatch, int eflags)
+ {
+-#ifdef HAVE_G_REGEX_ERROR_STRAY_BACKSLASH
+ int eoptions =
+ ((eflags & GO_REG_NOTBOL) ? G_REGEX_MATCH_NOTBOL : 0) |
+ ((eflags & GO_REG_NOTEOL) ? G_REGEX_MATCH_NOTEOL : 0);
+@@ -196,62 +146,6 @@ go_regexec (const GORegexp *gor, const char *txt,
+ g_match_info_free (match_info);
+
+ return matched ? GO_REG_NOERROR : GO_REG_NOMATCH;
+-#else
+- size_t txtlen = strlen (txt);
+- int eoptions =
+- ((eflags & GO_REG_NOTBOL) ? PCRE_NOTBOL : 0) |
+- ((eflags & GO_REG_NOTEOL) ? PCRE_NOTEOL : 0);
+- int res;
+- int *offsets, *allocated;
+- int offsetcount;
+- if (gor->nosub)
+- nmatch = 0;
+-
+- if (nmatch > 0) {
+- /* Paranoia. */
+- if (nmatch >= G_MAXINT / sizeof (int) / 3)
+- return GO_REG_ESPACE;
+-
+- offsetcount = nmatch * 3;
+- offsets = allocated = g_try_new (int, offsetcount);
+- if (!offsets)
+- return GO_REG_ESPACE;
+- } else {
+- offsets = allocated = NULL;
+- offsetcount = 0;
+- }
+-
+- res = pcre_exec (gor->ppcre, NULL, txt, txtlen, 0, eoptions,
+- offsets, offsetcount);
+- if (res >= 0) {
+- int i;
+-
+- if (res == 0) res = nmatch;
+-
+- for (i = 0; i < res; i++) {
+- pmatch[i].rm_so = offsets[i * 2];
+- pmatch[i].rm_eo = offsets[i * 2 + 1];
+- }
+- for (; i < (int)nmatch; i++) {
+- pmatch[i].rm_so = -1;
+- pmatch[i].rm_eo = -1;
+- }
+- g_free (allocated);
+- return GO_REG_NOERROR;
+- }
+-
+- g_free (allocated);
+- switch (res) {
+- case PCRE_ERROR_NOMATCH:
+- return GO_REG_NOMATCH;
+- case PCRE_ERROR_BADUTF8:
+- case PCRE_ERROR_BADUTF8_OFFSET:
+- /* POSIX doesn't seem to foresee this kind of error. */
+- return GO_REG_BADPAT;
+- default:
+- return GO_REG_ESPACE;
+- }
+-#endif
+ }
+
+ /* ------------------------------------------------------------------------- */
+--
+1.7.8.5
+
diff --git a/x11-libs/goffice/goffice-0.10.21.ebuild b/x11-libs/goffice/goffice-0.10.21.ebuild
new file mode 100644
index 000000000000..66d2214f0fff
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.21.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# Build fails with -gtk
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.8.7:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+# eautoreconf requires:
+# gnome-base/gnome-common
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
diff --git a/x11-libs/goffice/goffice-0.10.22.ebuild b/x11-libs/goffice/goffice-0.10.22.ebuild
new file mode 100644
index 000000000000..66d2214f0fff
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.10.22.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.10"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection"
+
+# Build fails with -gtk
+# FIXME: add lasem to tree
+RDEPEND="
+ >=app-text/libspectre-0.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.22:2
+ >=gnome-extra/libgsf-1.14.24:=[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24:=
+ >=x11-libs/cairo-1.10:=[svg]
+ x11-libs/libXext:=
+ x11-libs/libXrender:=
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/gtk+-3.8.7:3
+ introspection? (
+ >=dev-libs/gobject-introspection-1:=
+ >=gnome-extra/libgsf-1.14.23:= )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long
+ virtual/perl-IO-Compress
+ virtual/perl-Compress-Raw-Zlib
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+# eautoreconf requires:
+# gnome-base/gnome-common
+
+src_configure() {
+ gnome2_src_configure \
+ --without-lasem \
+ --with-gtk \
+ --with-config-backend=gsettings \
+ $(use_enable introspection)
+}
diff --git a/x11-libs/goffice/goffice-0.8.17-r1.ebuild b/x11-libs/goffice/goffice-0.8.17-r1.ebuild
new file mode 100644
index 000000000000..310d040e9bf8
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.8.17-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://git.gnome.org/browse/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.8"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="doc gnome"
+
+# Build fails with -gtk
+# FIXME: add lasem to tree
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=gnome-extra/libgsf-1.14.9
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/cairo-1.2[svg]
+ x11-libs/libXext
+ x11-libs/libXrender
+ >=x11-libs/gtk+-2.16:2
+ gnome? ( >=gnome-base/gconf-2:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.11 )
+
+ dev-util/gtk-doc-am
+ gnome-base/gnome-common"
+# eautoreconf requires: gtk-doc-am, gnome-common
+
+pkg_setup() {
+ DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+ # Gsettings is still experimental
+ if use gnome; then
+ G2CONF="${G2CONF} --with-config-backend=gconf"
+ else
+ G2CONF="${G2CONF} --with-config-backend=keyfile"
+ fi
+
+ G2CONF="${G2CONF}
+ --without-lasem
+ --with-gtk"
+
+ filter-flags -ffast-math
+}
+
+src_prepare() {
+ # bug #404271, https://bugzilla.gnome.org/show_bug.cgi?id=670316
+ epatch "${FILESDIR}/${P}-no-pcre.patch"
+ eautoreconf
+ gnome2_src_prepare
+}
diff --git a/x11-libs/goffice/metadata.xml b/x11-libs/goffice/metadata.xml
new file mode 100644
index 000000000000..cbc0c75add28
--- /dev/null
+++ b/x11-libs/goffice/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-office</herd>
+ <longdescription lang="en">
+ GOffice is a library of document-centric objects and utilities building
+ on top of GLib and Gtk+ and used by software such as Gnumeric.
+ </longdescription>
+</pkgmetadata>
+