summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/goocanvas')
-rw-r--r--x11-libs/goocanvas/Manifest2
-rw-r--r--x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch26
-rw-r--r--x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch30
-rw-r--r--x11-libs/goocanvas/goocanvas-1.0.0.ebuild58
-rw-r--r--x11-libs/goocanvas/goocanvas-2.0.2.ebuild69
-rw-r--r--x11-libs/goocanvas/metadata.xml5
6 files changed, 190 insertions, 0 deletions
diff --git a/x11-libs/goocanvas/Manifest b/x11-libs/goocanvas/Manifest
new file mode 100644
index 000000000000..218d6f1b2fbe
--- /dev/null
+++ b/x11-libs/goocanvas/Manifest
@@ -0,0 +1,2 @@
+DIST goocanvas-1.0.0.tar.bz2 570552 SHA256 1c072ef88567cad241fb4addee26e9bd96741b1503ff736d1c152fa6d865711e SHA512 fef4364b57dc777b6dcceb026f940121a24a8a3792e8d37d320eb47b7747ab0d54d8d7911b4ff77c21ca2b251937c9312da04221bbc246a07bbf4062689de644 WHIRLPOOL fb8592136bacf10d73e3aeeac9366c0614f8cd60e74a30d31e475b1ae9a1ac76c97b64837490f916733d31191a90c121ac0d60e077acef7cc61a861f5b57fde7
+DIST goocanvas-2.0.2.tar.xz 502732 SHA256 f20e5fbef8d1a2633033edbd886dd13146a1b948d1813a9c353a80a29295d1d0 SHA512 2b3014b832a5426884aa472fbfabcca171ef90305afccd312583d259517725a1839509e39b13b30c5097bf54ed9b3dfd2bf9eeca4e813a82d14cf1d5a54578ac WHIRLPOOL 714682b70d747e5db94140e5067e4df3c396332cab9f8b112141f39135758cea0a7e07405d796a70d81b95b76ce68ec17c58b317d0508dc413f2e6139dc39c87
diff --git a/x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch b/x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch
new file mode 100644
index 000000000000..c395c6ffd797
--- /dev/null
+++ b/x11-libs/goocanvas/files/goocanvas-1.0.0-gold.patch
@@ -0,0 +1,26 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index b49c009..9c3316b 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -12,7 +12,7 @@ INCLUDES = \
+
+ lib_LTLIBRARIES = libgoocanvas.la
+
+-libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+
+ if PLATFORM_WIN32
+ no_undefined = -no-undefined
+diff --git a/src/Makefile.in b/src/Makefile.in
+index c4d43b2..8d555fe 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -254,7 +254,7 @@ INCLUDES = \
+ # -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ # -DGTK_DISABLE_DEPRECATED
+ lib_LTLIBRARIES = libgoocanvas.la
+-libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+ @PLATFORM_WIN32_TRUE@no_undefined = -no-undefined
+ libtool_opts = \
+ -version-info $(LT_VERSION_INFO) \
diff --git a/x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch b/x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch
new file mode 100644
index 000000000000..c37dc4efef89
--- /dev/null
+++ b/x11-libs/goocanvas/files/goocanvas-2.0.1-gold.patch
@@ -0,0 +1,30 @@
+ src/Makefile.am | 2 +-
+ src/Makefile.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 2052baa..e5d9693 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -12,7 +12,7 @@ INCLUDES = \
+
+ lib_LTLIBRARIES = libgoocanvas-2.0.la
+
+-libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+
+ if PLATFORM_WIN32
+ no_undefined = -no-undefined
+diff --git a/src/Makefile.in b/src/Makefile.in
+index 1d927b9..15b9316 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -297,7 +297,7 @@ INCLUDES = \
+ # -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED \
+ # -DGTK_DISABLE_DEPRECATED
+ lib_LTLIBRARIES = libgoocanvas-2.0.la
+-libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS)
++libgoocanvas_2_0_la_LIBADD = @PACKAGE_LIBS@ $(INTLLIBS) -lm
+ @PLATFORM_WIN32_TRUE@no_undefined = -no-undefined
+ libtool_opts = \
+ -version-info $(LT_VERSION_INFO) \
diff --git a/x11-libs/goocanvas/goocanvas-1.0.0.ebuild b/x11-libs/goocanvas/goocanvas-1.0.0.ebuild
new file mode 100644
index 000000000000..a78abe91b2ce
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-1.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG=no
+GNOME2_LA_PUNT=yes
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2 libtool
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/Projects/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.12:2
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/cairo-1.4
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=671766
+ epatch "${FILESDIR}"/${P}-gold.patch
+
+ # Fails to build with recent GTK+
+ sed -e "s/-D.*_DISABLE_DEPRECATED//g" \
+ -i src/Makefile.am src/Makefile.in demo/Makefile.am demo/Makefile.in \
+ || die "sed 1 failed"
+
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/examples/
+ doins demo/*.c demo/flower.png demo/toroid.png
+ fi
+}
diff --git a/x11-libs/goocanvas/goocanvas-2.0.2.ebuild b/x11-libs/goocanvas/goocanvas-2.0.2.ebuild
new file mode 100644
index 000000000000..b75bb5980ccf
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-2.0.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="examples +introspection python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# python only enables python specific binding override
+RDEPEND="
+ >=x11-libs/gtk+-3.0.0:3
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.90.4:3[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed failed"
+
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS = python/d" -i bindings/Makefile.am bindings/Makefile.in
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python; then
+ sub_install() {
+ python_moduleinto $(python -c "import gi;print gi._overridesdir")
+ python_domodule bindings/python/GooCanvas.py
+ }
+ python_foreach_impl sub_install
+ fi
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}
diff --git a/x11-libs/goocanvas/metadata.xml b/x11-libs/goocanvas/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/x11-libs/goocanvas/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>