summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libSM')
-rw-r--r--x11-libs/libSM/Manifest1
-rw-r--r--x11-libs/libSM/libSM-1.2.2-r1.ebuild58
-rw-r--r--x11-libs/libSM/metadata.xml10
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-libs/libSM/Manifest b/x11-libs/libSM/Manifest
new file mode 100644
index 000000000000..9167550bad8d
--- /dev/null
+++ b/x11-libs/libSM/Manifest
@@ -0,0 +1 @@
+DIST libSM-1.2.2.tar.bz2 348908 SHA256 0baca8c9f5d934450a70896c4ad38d06475521255ca63b717a6510fdb6e287bd SHA512 dfb91dcc7200fce8d0a62953ae4b81fcb00d525674bbcc6dfcaa23ecb35e1213ceb07cc51f590072dce2107909903160d9f3636a0434fe2a605b1e9a9bd0a6ca WHIRLPOOL d9b45a64ccc85b6ed2eb181bc01e8b9c8b839dfb2b41067665688ee27c7d35cb6f3661f96966bb7c8256b1d9391f613cd11b1ccfc9d3a4c362167fa7b77b135b
diff --git a/x11-libs/libSM/libSM-1.2.2-r1.ebuild b/x11-libs/libSM/libSM-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..a4547e8a2ab2
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.2-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Session Management library"
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="doc ipv6 +uuid"
+
+RDEPEND=">=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+ x11-libs/xtrans
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ !elibc_FreeBSD? ( !elibc_SunOS? ( !elibc_Darwin? (
+ uuid? ( >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}] )
+ ) ) )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local withuuid=$(use_with uuid libuuid)
+
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+
+ if use uuid ; then
+ case ${CHOST} in
+ *-solaris*|*-darwin*)
+ if [[ ! -d ${EROOT}usr/include/uuid ]] &&
+ [[ -d ${ROOT}usr/include/uuid ]]
+ then
+ # Solaris and Darwin have uuid provided by the host
+ # system. Since util-linux's version is based on this
+ # version, and on Darwin actually breaks host headers when
+ # installed, we can "pretend" for libSM we have libuuid
+ # installed, while in fact we don't
+ withuuid="--without-libuuid"
+ export HAVE_LIBUUID=yes
+ export LIBUUID_CFLAGS="-I${ROOT}usr/include/uuid"
+ # Darwin has uuid in libSystem
+ [[ ${CHOST} == *-solaris* ]] && export LIBUUID_LIBS="-luuid"
+ fi
+ ;;
+ esac
+ fi
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ ${withuuid}
+ --without-fop
+ )
+ xorg-2_src_configure
+}
diff --git a/x11-libs/libSM/metadata.xml b/x11-libs/libSM/metadata.xml
new file mode 100644
index 000000000000..8b3fa73a30b0
--- /dev/null
+++ b/x11-libs/libSM/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name="uuid">Use UUID for session identification instead of IP address
+ and system time.
+ </flag>
+</use>
+</pkgmetadata>