summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libaosd/libaosd-0.2.7.ebuild')
-rw-r--r--x11-libs/libaosd/libaosd-0.2.7.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-libs/libaosd/libaosd-0.2.7.ebuild b/x11-libs/libaosd/libaosd-0.2.7.ebuild
new file mode 100644
index 000000000000..85c380421de6
--- /dev/null
+++ b/x11-libs/libaosd/libaosd-0.2.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="An advanced on screen display (OSD) library"
+HOMEPAGE="https://github.com/atheme/libaosd"
+SRC_URI="https://github.com/atheme/${PN}/archive/0.2.7.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="pango +tools xcomposite"
+
+RDEPEND="
+ x11-libs/cairo[X]
+ x11-libs/libX11
+ x11-libs/libXrender
+ pango? ( x11-libs/pango )
+ tools? ( dev-libs/glib:2 )
+ xcomposite? ( x11-libs/libXcomposite )
+"
+DEPEND="${RDEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=( Changelog )
+
+src_prepare() {
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable tools glib)
+ $(use_enable pango pangocairo)
+ $(use_enable xcomposite)
+ )
+
+ autotools-utils_src_configure
+}