summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libfakekey')
-rw-r--r--x11-libs/libfakekey/Manifest1
-rw-r--r--x11-libs/libfakekey/files/libfakekey-0.1-ac.patch24
-rw-r--r--x11-libs/libfakekey/libfakekey-0.1-r1.ebuild47
-rw-r--r--x11-libs/libfakekey/libfakekey-0.1-r2.ebuild46
-rw-r--r--x11-libs/libfakekey/metadata.xml6
5 files changed, 124 insertions, 0 deletions
diff --git a/x11-libs/libfakekey/Manifest b/x11-libs/libfakekey/Manifest
new file mode 100644
index 000000000000..5c5ba02a83f7
--- /dev/null
+++ b/x11-libs/libfakekey/Manifest
@@ -0,0 +1 @@
+DIST libfakekey-0.1.tar.bz2 203504 SHA256 c41042a70524895b0edf8077ae3ae1206f1a313bea5811dcc23033ea16a00194 SHA512 1fda0548cf14657083a6602f8d6c08efae8cae2236de7ed17fc4058765156c6bb923956e3c7fd75f2db586399f1d8a3320ab5bbed71cc5a8b0d146590a14a808 WHIRLPOOL c33c01b745a1f3fd81333847a09ec1f5d11552976f2034e22bb323ae8cbd6f3d4ef819969d40f063d727f11004c77713fe906361433a7e467c2083ef0f0f3702
diff --git a/x11-libs/libfakekey/files/libfakekey-0.1-ac.patch b/x11-libs/libfakekey/files/libfakekey-0.1-ac.patch
new file mode 100644
index 000000000000..65c0b083aa72
--- /dev/null
+++ b/x11-libs/libfakekey/files/libfakekey-0.1-ac.patch
@@ -0,0 +1,24 @@
+--- configure.ac.old 2011-05-22 14:59:45.801746472 +0100
++++ configure.ac 2011-05-22 15:02:59.437159981 +0100
+@@ -14,16 +14,14 @@ AC_HEADER_STDC
+
+ dnl ------ libtool versioning -----------------------------------------------
+
+-LT_CURRENT=0
+-LT_REVISION=1
+-AC_SUBST(LT_CURRENT)
+-AC_SUBST(LT_REVISION)
+-LT_AGE=0
++m4_define(LT_CURRENT, 0)
++m4_define(LT_REVISION, 1)
++m4_define(LT_AGE, 0)
+
+-LT_VERSION_INFO="$LT_CURRENT:$LT_REVISION:$LT_AGE"
++LT_VERSION_INFO="LT_CURRENT():LT_REVISION():LT_AGE()"
+ AC_SUBST(LT_VERSION_INFO)
+
+-LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
++LT_CURRENT_MINUS_AGE="m4_eval(LT_CURRENT() - LT_AGE())"
+ AC_SUBST(LT_CURRENT_MINUS_AGE)
+
+ dnl ------ Check for X Stuff ------------------------------------------------
diff --git a/x11-libs/libfakekey/libfakekey-0.1-r1.ebuild b/x11-libs/libfakekey/libfakekey-0.1-r1.ebuild
new file mode 100644
index 000000000000..f45ed221ccee
--- /dev/null
+++ b/x11-libs/libfakekey/libfakekey-0.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils autotools
+
+DESCRIPTION="Helper library for the x11-misc/matchbox-keyboard package"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm ~hppa ppc x86"
+IUSE="debug doc"
+
+RDEPEND="x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # Allow configure to use libtool-2
+ epatch "${FILESDIR}/${P}-ac.patch"
+
+ # Fix underlinking bug #367595
+ sed -i -e 's/^fakekey_test_LDADD=/fakekey_test_LDADD=-lX11 /' \
+ tests/Makefile.am || die 'Cannot sed Makefile.am'
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # --with/without-x is ignored by configure script and X is used.
+ econf --with-x \
+ $(use_enable debug) \
+ $(use_enable doc doxygen-docs) \
+ || die "Configuration failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ use doc && dohtml doc/html/*
+}
diff --git a/x11-libs/libfakekey/libfakekey-0.1-r2.ebuild b/x11-libs/libfakekey/libfakekey-0.1-r2.ebuild
new file mode 100644
index 000000000000..90a07a32c607
--- /dev/null
+++ b/x11-libs/libfakekey/libfakekey-0.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Helper library for the x11-misc/matchbox-keyboard package"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="debug doc"
+
+RDEPEND="x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # Allow configure to use libtool-2
+ epatch "${FILESDIR}/${P}-ac.patch"
+
+ # Fix underlinking bug #367595
+ sed -i -e 's/^fakekey_test_LDADD=/fakekey_test_LDADD=-lX11 /' \
+ tests/Makefile.am || die 'Cannot sed Makefile.am'
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # --with/without-x is ignored by configure script and X is used.
+ econf --with-x \
+ $(use_enable debug) \
+ $(use_enable doc doxygen-docs)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ use doc && dohtml doc/html/*
+}
diff --git a/x11-libs/libfakekey/metadata.xml b/x11-libs/libfakekey/metadata.xml
new file mode 100644
index 000000000000..13070094fdcc
--- /dev/null
+++ b/x11-libs/libfakekey/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gpe</herd>
+ <herd>kde</herd>
+</pkgmetadata>