summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libmatchbox')
-rw-r--r--x11-libs/libmatchbox/Manifest2
-rw-r--r--x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch13
-rw-r--r--x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch22
-rw-r--r--x11-libs/libmatchbox/files/libmatchbox-1.9-underlinking.patch12
-rw-r--r--x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild71
-rw-r--r--x11-libs/libmatchbox/metadata.xml13
6 files changed, 133 insertions, 0 deletions
diff --git a/x11-libs/libmatchbox/Manifest b/x11-libs/libmatchbox/Manifest
new file mode 100644
index 000000000000..1257d031b3e1
--- /dev/null
+++ b/x11-libs/libmatchbox/Manifest
@@ -0,0 +1,2 @@
+DIST check-0.9.12.tar.gz 730404 SHA256 c7d47e55e133a0ca19a52e08a99333ac55cb22618b53719b7f4117a1875b1ea3 SHA512 698e6cfdf24b07340fb4fa77f49811053f8307d3baca8bdcdde5e3dfe1f910bbadb6a393f03020d8b18c22e7e164d40f6bbbeb9659908b0df8459e5c4850fa50 WHIRLPOOL 4994c444532e1337bcda5e632d532ffd6aae59de866009b5bce3d1f25988dd203d04136dd451b6d24c6e32775159772d1c98097ff618a5cc559fca9725ad18ed
+DIST libmatchbox-1.9.tar.bz2 316575 SHA256 db01e218e8d09540459c8f7c5698c159cd84c3d5b8caa9763bf0e5a35f6edf00 SHA512 1834a096f1627fd51ef17a0a49a32b6a1b9e4f5022d9409b7dcb531f409aa67c16c3c4d52ed2ca881193879f624d8efb15d1bd950b653ce1cf5823b9200c9964 WHIRLPOOL f2692f76573dbe0860d3ba89b6e792f4add758687d074db7f2c70ce8757a6483802b71831d02dee8aae9e8268977b3ea23e3fbc9aeec19148bdc4662d59aea62
diff --git a/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch
new file mode 100644
index 000000000000..6ba3c49243a0
--- /dev/null
+++ b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng14.patch
@@ -0,0 +1,13 @@
+http://projects.archlinux.org/svntogit/community.git/tree/libmatchbox/trunk/PKGBUILD?id=43f68b59fb790eb685d18a2f189c7e3055c77b30
+
+--- libmb/mbpixbuf.c
++++ libmb/mbpixbuf.c
+@@ -228,7 +228,7 @@
+ if ((fd = fopen( file, "rb" )) == NULL) return NULL;
+
+ fread( header, 1, 8, fd );
+- if ( ! png_check_sig( header, 8 ) )
++ if ( ! png_sig_cmp( header, 0, 8 ) == 0 )
+ {
+ fclose(fd);
+ return NULL;
diff --git a/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch
new file mode 100644
index 000000000000..25f68575032c
--- /dev/null
+++ b/x11-libs/libmatchbox/files/libmatchbox-1.9-libpng15.patch
@@ -0,0 +1,22 @@
+--- libmb/mbpixbuf.c
++++ libmb/mbpixbuf.c
+@@ -247,7 +247,7 @@
+ return NULL;
+ }
+
+- if ( setjmp( png_ptr->jmpbuf ) ) {
++ if ( setjmp( png_jmpbuf(png_ptr) ) ) {
+ png_destroy_read_struct( &png_ptr, &info_ptr, NULL);
+ fclose(fd);
+ return NULL;
+@@ -269,8 +269,8 @@
+ ( color_type == PNG_COLOR_TYPE_GRAY_ALPHA ))
+ png_set_gray_to_rgb(png_ptr);
+
+- if ( info_ptr->color_type == PNG_COLOR_TYPE_RGB_ALPHA
+- || info_ptr->color_type == PNG_COLOR_TYPE_GRAY_ALPHA
++ if ( color_type == PNG_COLOR_TYPE_RGB_ALPHA
++ || color_type == PNG_COLOR_TYPE_GRAY_ALPHA
+ )
+ *has_alpha = 1;
+ else
diff --git a/x11-libs/libmatchbox/files/libmatchbox-1.9-underlinking.patch b/x11-libs/libmatchbox/files/libmatchbox-1.9-underlinking.patch
new file mode 100644
index 000000000000..f8b2feeea332
--- /dev/null
+++ b/x11-libs/libmatchbox/files/libmatchbox-1.9-underlinking.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/367683
+
+--- tests/Makefile.am
++++ tests/Makefile.am
+@@ -19,6 +19,7 @@
+
+ noinst_PROGRAMS = dump-image
+ dump_image_SOURCES=dump-image.c
++dump_image_LDADD= @XLIBS_LIBS@
+
+ EXTRA_DIST = oh-overlayed.png oh.png oh-scaled.png overlay.png oh.jpg oh.xpm \
+ dot-desktop.c pixbuf.c oh.h
diff --git a/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild b/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
new file mode 100644
index 000000000000..b8b5e0dacb39
--- /dev/null
+++ b/x11-libs/libmatchbox/libmatchbox-1.9-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="The Matchbox Library"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/${PV}/${P}.tar.bz2
+ mirror://sourceforge/check/check-0.9.12.tar.gz" # For check.m4
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~mips ppc x86"
+IUSE="debug doc jpeg pango png static-libs test truetype X xsettings"
+
+RDEPEND="x11-libs/libXext:=
+ truetype? ( x11-libs/libXft:= )
+ pango? ( x11-libs/pango:= )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0= )
+ xsettings? ( x11-libs/libxsettings-client )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )"
+
+# Test suite broken, missing files and such.
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+pkg_setup() {
+ # Bug #138135
+ if use truetype && use pango; then
+ ewarn "You have both the truetype and pango USE flags set, pango"
+ ewarn "overrides and disables the XFT support truetype enables."
+ ewarn "If this isn't what you intended you should stop the build!"
+ fi
+}
+
+src_prepare() {
+ mv "${WORKDIR}"/check-*/check.m4 "${WORKDIR}"/ || die
+
+ epatch \
+ "${FILESDIR}"/${P}-libpng1{4,5}.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+
+ AT_M4DIR="${WORKDIR}" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(use_enable doc doxygen-docs) \
+ $(use_enable truetype xft) \
+ $(use_enable pango) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable xsettings) \
+ $(use_with X x) \
+ $(use_enable test unit-tests)
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/html/*
+
+ prune_libtool_files --all
+}
diff --git a/x11-libs/libmatchbox/metadata.xml b/x11-libs/libmatchbox/metadata.xml
new file mode 100644
index 000000000000..a7fef72f1e2f
--- /dev/null
+++ b/x11-libs/libmatchbox/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gpe</herd>
+ <use>
+ <flag name="pango">Enable <pkg>x11-libs/pango</pkg> support</flag>
+ <flag name="xsettings">Enable the use of xsettings for settings
+ management</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">check</remote-id>
+ </upstream>
+</pkgmetadata>