summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/scw/scw-0.4.7.ebuild')
-rw-r--r--x11-libs/scw/scw-0.4.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-libs/scw/scw-0.4.7.ebuild b/x11-libs/scw/scw-0.4.7.ebuild
new file mode 100644
index 000000000000..9bfc7a1c3b5f
--- /dev/null
+++ b/x11-libs/scw/scw-0.4.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+DESCRIPTION="A GTK+ widget set specifically designed for chat programs"
+HOMEPAGE="http://scwwidgets.googlepages.com"
+SRC_URI="http://scwwidgets.googlepages.com/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}