summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xpyb')
-rw-r--r--x11-libs/xpyb/Manifest1
-rw-r--r--x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch11
-rw-r--r--x11-libs/xpyb/files/xpyb-python.patch12
-rw-r--r--x11-libs/xpyb/metadata.xml5
-rw-r--r--x11-libs/xpyb/xpyb-1.3.1-r2.ebuild47
-rw-r--r--x11-libs/xpyb/xpyb-1.3.1-r3.ebuild50
6 files changed, 126 insertions, 0 deletions
diff --git a/x11-libs/xpyb/Manifest b/x11-libs/xpyb/Manifest
new file mode 100644
index 000000000000..a35e4d1d142c
--- /dev/null
+++ b/x11-libs/xpyb/Manifest
@@ -0,0 +1 @@
+DIST xpyb-1.3.1.tar.bz2 273962 SHA256 fd4c877b05b83893043734a678eca332c6cabf1867d9b6a966c28a97ac987366 SHA512 f3020f9b9d27ae522408d22cbdb14c9eb3d4acbc911e6f8fac425323c3f99233f773c3c4e027aa3812dec11b832cf0df8a38f71d21b0c3a1918eea6efe36c090 WHIRLPOOL 8cb9289125bd6860590c86eeaaddadde32452cdbc64c63f3f82c85ac627378da203f3e1b6331a213e3a17eed3d0d179d1ba5f6279bf613a7cca870a242f81fab
diff --git a/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch b/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch
new file mode 100644
index 000000000000..1196741b3cbe
--- /dev/null
+++ b/x11-libs/xpyb/files/xpyb-1.3.1-xcbproto-1.9.patch
@@ -0,0 +1,11 @@
+diff -ruN xpyb-1.3.1_ORIG/src/py_client.py xpyb-1.3.1/src/py_client.py
+--- xpyb-1.3.1_ORIG/src/py_client.py 2013-11-17 12:57:05.157530931 +0100
++++ xpyb-1.3.1/src/py_client.py 2013-11-17 12:57:52.221530100 +0100
+@@ -19,6 +19,7 @@
+ 'INT8': 'b', 'int8_t': 'b',
+ 'INT16': 'h', 'int16_t': 'h',
+ 'INT32': 'i', 'int32_t': 'i',
++ 'INT64': 'i', 'int64_t': 'i',
+ 'BYTE': 'B',
+ 'BOOL': 'B',
+ 'char': 'b',
diff --git a/x11-libs/xpyb/files/xpyb-python.patch b/x11-libs/xpyb/files/xpyb-python.patch
new file mode 100644
index 000000000000..4d5d9ac72956
--- /dev/null
+++ b/x11-libs/xpyb/files/xpyb-python.patch
@@ -0,0 +1,12 @@
+--- xpyb-1.3.1/configure.ac.orig 2013-05-21 19:01:51.054962821 +0400
++++ xpyb-1.3.1/configure.ac 2013-05-21 19:05:22.342961464 +0400
+@@ -38,7 +38,8 @@
+
+ # Find the xcbgen Python package
+ AC_MSG_CHECKING([for xcb-proto python dir])
+-XCBPROTO_XCBPYTHONDIR=`$PKG_CONFIG --variable=pythondir xcb-proto`
++XCBPROTO_XCBPYTHONDIR=`$PYTHON -c 'import xcbgen; from os.path import dirname, abspath, join; \
++ print abspath(join(dirname(xcbgen.[__file__]), ".."))'`
+ AC_MSG_RESULT($XCBPROTO_XCBPYTHONDIR)
+ AC_SUBST(XCBPROTO_XCBPYTHONDIR)
+
diff --git a/x11-libs/xpyb/metadata.xml b/x11-libs/xpyb/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-libs/xpyb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild b/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..c563aa3c8b1e
--- /dev/null
+++ b/x11-libs/xpyb/xpyb-1.3.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=1
+
+inherit flag-o-matic xorg-2 python-r1
+
+#EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+DESCRIPTION="XCB-based Python bindings for the X Window System"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="selinux"
+
+RDEPEND=">=x11-libs/libxcb-1.7
+ >=x11-proto/xcb-proto-1.7.1[${PYTHON_USEDEP}]
+ <x11-proto/xcb-proto-1.9
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-python.patch )
+DOCS=( NEWS README )
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable selinux)
+ )
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+ python_foreach_impl xorg-2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl xorg-2_src_compile
+}
+
+src_install() {
+ python_foreach_impl xorg-2_src_install
+}
diff --git a/x11-libs/xpyb/xpyb-1.3.1-r3.ebuild b/x11-libs/xpyb/xpyb-1.3.1-r3.ebuild
new file mode 100644
index 000000000000..bba57549f3df
--- /dev/null
+++ b/x11-libs/xpyb/xpyb-1.3.1-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=1
+
+inherit flag-o-matic xorg-2 python-r1
+
+#EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/xpyb"
+SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+DESCRIPTION="XCB-based Python bindings for the X Window System"
+HOMEPAGE="http://xcb.freedesktop.org/"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="selinux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=x11-libs/libxcb-1.7
+ >=x11-proto/xcb-proto-1.7.1[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-python.patch
+ "${FILESDIR}"/${PN}-1.3.1-xcbproto-1.9.patch
+)
+DOCS=( NEWS README )
+
+pkg_setup() {
+ xorg-2_pkg_setup
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable selinux)
+ )
+}
+
+src_configure() {
+ append-cflags -fno-strict-aliasing
+ python_foreach_impl xorg-2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl xorg-2_src_compile
+}
+
+src_install() {
+ python_foreach_impl xorg-2_src_install
+}