summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xtrans/xtrans-1.3.3.ebuild')
-rw-r--r--x11-libs/xtrans/xtrans-1.3.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-libs/xtrans/xtrans-1.3.3.ebuild b/x11-libs/xtrans/xtrans-1.3.3.ebuild
new file mode 100644
index 000000000000..536d97524c53
--- /dev/null
+++ b/x11-libs/xtrans/xtrans-1.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_PACKAGE_NAME="lib${PN}"
+# this package just installs some .c and .h files, no libraries
+XORG_STATIC=no
+XORG_DOC=doc
+inherit xorg-2
+
+DESCRIPTION="X.Org xtrans library"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}