summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/grsync')
-rw-r--r--x11-misc/grsync/Manifest3
-rw-r--r--x11-misc/grsync/files/grsync-1.3.0-desktop.patch24
-rw-r--r--x11-misc/grsync/files/grsync-1.3.0-nested_func.patch21
-rw-r--r--x11-misc/grsync/grsync-1.2.6.ebuild24
-rw-r--r--x11-misc/grsync/grsync-1.3.0.ebuild36
-rw-r--r--x11-misc/grsync/grsync-1.3.1.ebuild37
-rw-r--r--x11-misc/grsync/metadata.xml5
7 files changed, 124 insertions, 26 deletions
diff --git a/x11-misc/grsync/Manifest b/x11-misc/grsync/Manifest
index fa7e2c7db8b8..34c75a3e0a8d 100644
--- a/x11-misc/grsync/Manifest
+++ b/x11-misc/grsync/Manifest
@@ -1 +1,2 @@
-DIST grsync-1.2.6.tar.gz 333540 BLAKE2B 20719580309aba5737b74e85629b21b9715ceb8d97bd00d1840a5eda0e04316439d90999b7b787cdf8b368fff90ba489dcfc3b91992dd599f7ae05f4a565f1e7 SHA512 a7aac0cf264c968d50896156730dc0b925045def6e513adf1f2783e19fd1cdd423aa69480963479b95927fb4e863f110f3fc0439661ef7cfcacc7376fe95ff1d
+DIST grsync-1.3.0.tar.gz 304725 BLAKE2B 4e58eb7db8082b733468b95db995a2e7f7f970cebe2b3eb614e0a828d2fb34bc20fc2163f8bca7d5d87e648cfe0dd45a0cd22319d6504e9bd491a6da462ee8a3 SHA512 2d2d9e7910f18e061c5259f51510cd5e3c14c1c15b649618ea096777531780c2d5821a7bb415cd762a695302146b4835d793d31c032667431e227ac11a7aa108
+DIST grsync-1.3.1.tar.gz 302904 BLAKE2B 26bfdc0787ed3340df866f21cad79bba6ad6bb91abc834338be1dfcbe8ae464b755b4d5832586dafb416e8e88ef97a06074b5018d14ba415f625e24c66c42bef SHA512 af3e70108085ad240b8f692f4fd389e7df42448291b721e923fb7e7309e52a673a034583e68684820b47e520386c382efe56820da7b0e7146407bd3d09f2dc72
diff --git a/x11-misc/grsync/files/grsync-1.3.0-desktop.patch b/x11-misc/grsync/files/grsync-1.3.0-desktop.patch
new file mode 100644
index 000000000000..5cdc49194371
--- /dev/null
+++ b/x11-misc/grsync/files/grsync-1.3.0-desktop.patch
@@ -0,0 +1,24 @@
+diff -Naur grsync-1.3.0.orig/configure.in grsync-1.3.0/configure.in
+--- grsync-1.3.0.orig/configure.in 2020-05-28 10:16:05.000000000 +0200
++++ grsync-1.3.0/configure.in 2020-12-04 09:30:40.082105813 +0100
+@@ -30,7 +30,7 @@
+ GTK_API_VERSION="2.0"
+ fi
+ pkg_modules="gtk+-$GTK_API_VERSION >= 2.16.0"
+-OTHER_DESKTOP_ENTRIES="Icon=grsync.png"
++OTHER_DESKTOP_ENTRIES="Icon=grsync"
+ MIMEINFO_XMLNS="xmlns='http://www.freedesktop.org/standards/shared-mime-info'"
+ MIME_OSSOCAT=""
+
+diff -Naur grsync-1.3.0.orig/grsync.desktop.in grsync-1.3.0/grsync.desktop.in
+--- grsync-1.3.0.orig/grsync.desktop.in 2015-09-11 13:21:28.000000000 +0200
++++ grsync-1.3.0/grsync.desktop.in 2020-12-04 09:30:50.473110946 +0100
+@@ -4,7 +4,7 @@
+ Terminal=false
+ Type=Application
+ MimeType=application/x-grsync-session;
+-Categories=Application;System;
++Categories=System;
+ GenericName=Synchronize files with rsync
+ GenericName[fr]=Interface GTK pour rsync
+ GenericName[it]=Sincronizza file con rsync
diff --git a/x11-misc/grsync/files/grsync-1.3.0-nested_func.patch b/x11-misc/grsync/files/grsync-1.3.0-nested_func.patch
new file mode 100644
index 000000000000..6d135674bac8
--- /dev/null
+++ b/x11-misc/grsync/files/grsync-1.3.0-nested_func.patch
@@ -0,0 +1,21 @@
+diff -Naur grsync-1.3.0.orig/src/callbacks.c grsync-1.3.0/src/callbacks.c
+--- grsync-1.3.0.orig/src/callbacks.c 2020-11-23 14:52:42.000000000 +0100
++++ grsync-1.3.0/src/callbacks.c 2020-12-04 09:18:27.573776667 +0100
+@@ -40,12 +40,12 @@
+ gboolean more = FALSE, first = TRUE;
+
+
+-void dialog_set_labels_selectable(GtkWidget *dialog) {
+- void _set_label_selectable(gpointer data, gpointer user_data) {
+- GtkWidget *widget = GTK_WIDGET(data);
+- if (GTK_IS_LABEL(widget)) gtk_label_set_selectable(GTK_LABEL(widget), TRUE);
+- }
++void _set_label_selectable(gpointer data, gpointer user_data) {
++ GtkWidget *widget = GTK_WIDGET(data);
++ if (GTK_IS_LABEL(widget)) gtk_label_set_selectable(GTK_LABEL(widget), TRUE);
++}
+
++void dialog_set_labels_selectable(GtkWidget *dialog) {
+ GtkWidget *area = gtk_message_dialog_get_message_area(GTK_MESSAGE_DIALOG(dialog));
+ GtkContainer *box = (GtkContainer *) area;
+ GList *children = gtk_container_get_children(box);
diff --git a/x11-misc/grsync/grsync-1.2.6.ebuild b/x11-misc/grsync/grsync-1.2.6.ebuild
deleted file mode 100644
index 86540cbfa78e..000000000000
--- a/x11-misc/grsync/grsync-1.2.6.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A gtk frontend to rsync"
-HOMEPAGE="http://www.opbyte.it/grsync/"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
-IUSE=""
-SRC_URI="http://www.opbyte.it/release/${P}.tar.gz"
-
-RDEPEND=">=x11-libs/gtk+-2.16:2
- net-misc/rsync"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-util/intltool"
-
-DOCS="AUTHORS NEWS README"
-
-src_configure() {
- econf --disable-unity
-}
diff --git a/x11-misc/grsync/grsync-1.3.0.ebuild b/x11-misc/grsync/grsync-1.3.0.ebuild
new file mode 100644
index 000000000000..2fc9967fc91b
--- /dev/null
+++ b/x11-misc/grsync/grsync-1.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg
+
+DESCRIPTION="A gtk frontend to rsync"
+HOMEPAGE="http://www.opbyte.it/grsync/"
+SRC_URI="http://www.opbyte.it/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="+gtk3"
+
+DEPEND="
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( >=x11-libs/gtk+-2.16:2 )"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+BDEPEND="virtual/pkgconfig
+ dev-util/intltool"
+
+DOCS="AUTHORS NEWS README"
+
+PATCHES=( "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-nested_func.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-unity $(use_enable gtk3)
+}
diff --git a/x11-misc/grsync/grsync-1.3.1.ebuild b/x11-misc/grsync/grsync-1.3.1.ebuild
new file mode 100644
index 000000000000..20da83187937
--- /dev/null
+++ b/x11-misc/grsync/grsync-1.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit xdg
+
+DESCRIPTION="A gtk frontend to rsync"
+HOMEPAGE="http://www.opbyte.it/grsync/"
+SRC_URI="http://www.opbyte.it/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk3"
+
+DEPEND="
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( >=x11-libs/gtk+-2.16:2 )"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+BDEPEND="virtual/pkgconfig
+ dev-util/intltool"
+
+DOCS="AUTHORS NEWS README"
+
+src_prepare() {
+ default
+
+ if ! use gtk3; then
+ sed -e "s/gtk_widget_override_font/gtk_widget_modify_font/" \
+ -i src/callbacks.c || die
+ fi
+}
+
+src_configure() {
+ econf --disable-unity $(use_enable gtk3)
+}
diff --git a/x11-misc/grsync/metadata.xml b/x11-misc/grsync/metadata.xml
index dc71e24a084b..a3e477085709 100644
--- a/x11-misc/grsync/metadata.xml
+++ b/x11-misc/grsync/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>voyageur@gentoo.org</email>
<name>Bernard Cafarelli</name>
</maintainer>
+ <use>
+ <flag name="gtk3">Link against <pkg>x11-libs/gtk+</pkg>:3 instead of <pkg>x11-libs/gtk+</pkg>:2</flag>
+ </use>
</pkgmetadata>