summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gtkdialog/gtkdialog-0.8.3-r1.ebuild')
-rw-r--r--x11-misc/gtkdialog/gtkdialog-0.8.3-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/gtkdialog/gtkdialog-0.8.3-r1.ebuild b/x11-misc/gtkdialog/gtkdialog-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..36198e494721
--- /dev/null
+++ b/x11-misc/gtkdialog/gtkdialog-0.8.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A small utility for fast and easy GUI building"
+HOMEPAGE="https://code.google.com/p/gtkdialog/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="glade vte"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ glade? ( gnome-base/libglade )
+ vte? ( x11-libs/vte:= )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ virtual/yacc
+"
+
+DOCS=( AUTHORS ChangeLog TODO )
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ epatch "${FILESDIR}"/${PN}-0.8.3-optdeps.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with glade) $(use_with vte)
+}
+
+src_install() {
+ # Stop make install from running gtk-update-icon-cache
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
+}