summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/hsetroot/hsetroot-1.0.2.ebuild')
-rw-r--r--x11-misc/hsetroot/hsetroot-1.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/hsetroot/hsetroot-1.0.2.ebuild b/x11-misc/hsetroot/hsetroot-1.0.2.ebuild
new file mode 100644
index 000000000000..277384ab5c16
--- /dev/null
+++ b/x11-misc/hsetroot/hsetroot-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Tool which allows you to compose wallpapers ('root pixmaps') for X"
+HOMEPAGE="http://thegraveyard.org/hsetroot.html"
+SRC_URI="http://cdn.thegraveyard.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ >=media-libs/imlib2-1.0.6.2003[X]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlinking.patch
+ # The pre-generated configure script contains unneeded deps
+ eautoreconf
+}