summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild')
-rw-r--r--x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild b/x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild
deleted file mode 100644
index 2218c7e93b9c..000000000000
--- a/x11-misc/obconf-qt/obconf-qt-0.13.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils gnome2-utils xdg-utils
-
-DESCRIPTION="Openbox window manager configuration tool"
-HOMEPAGE="https://lxqt.org/"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm ~arm64 x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-RDEPEND="
- dev-libs/glib:2
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- x11-wm/openbox:3
- x11-libs/libX11
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.5.0
- sys-apps/sed
- virtual/pkgconfig
-"
-
-src_configure() {
- local mycmakeargs=(
- -DPULL_TRANSLATIONS=OFF
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}