summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/polybar/polybar-9999.ebuild')
-rw-r--r--x11-misc/polybar/polybar-9999.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/x11-misc/polybar/polybar-9999.ebuild b/x11-misc/polybar/polybar-9999.ebuild
deleted file mode 100644
index 3d18bd3871c8..000000000000
--- a/x11-misc/polybar/polybar-9999.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils git-r3 python-single-r1
-
-DESCRIPTION="A fast and easy-to-use tool for creating status bars"
-HOMEPAGE="https://github.com/jaagr/polybar"
-EGIT_REPO_URI="https://github.com/jaagr/${PN}.git"
-EGIT_CLONE_TYPE="shallow"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-
-IUSE="alsa curl i3wm ipc mpd network pulseaudio"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- ${PYTHON_DEPS}
- x11-base/xcb-proto
- x11-libs/cairo[xcb]
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-wm
- x11-libs/xcb-util-xrm
- alsa? ( media-libs/alsa-lib )
- curl? ( net-misc/curl )
- i3wm? ( dev-libs/jsoncpp )
- mpd? ( media-libs/libmpdclient )
- network? ( net-wireless/wireless-tools )
- pulseaudio? ( media-sound/pulseaudio )
-"
-
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_ALSA="$(usex alsa)"
- -DENABLE_CURL="$(usex curl)"
- -DENABLE_I3="$(usex i3wm)"
- -DBUILD_IPC_MSG="$(usex ipc)"
- -DENABLE_MPD="$(usex mpd)"
- -DENABLE_NETWORK="$(usex network)"
- -DENABLE_PULSEAUDIO="$(usex pulseaudio)"
- )
- cmake-utils_src_configure
-}