summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rofi/rofi-1.5.2.ebuild')
-rw-r--r--x11-misc/rofi/rofi-1.5.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/rofi/rofi-1.5.2.ebuild b/x11-misc/rofi/rofi-1.5.2.ebuild
new file mode 100644
index 000000000000..ffb4b7ff5d39
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.5.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}