summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/slop/files/slop-4.3.21-no-opengl.patch')
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-opengl.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/x11-misc/slop/files/slop-4.3.21-no-opengl.patch b/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
deleted file mode 100644
index 2f596b65e992..000000000000
--- a/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 62cc1a6..f5d66e5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -71,14 +71,8 @@ endif()
-
- # Obtain library paths and make sure they exist.
- set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmakemodules" )
--find_package( Imlib2 REQUIRED )
- find_package( X11 REQUIRED )
- find_package( XExt REQUIRED )
--find_package( OpenGL REQUIRED )
--find_package( GLX REQUIRED )
--find_package( XRender REQUIRED )
--find_package( XRandr REQUIRED )
--find_package( GLEW REQUIRED )
-
- set( CMAKE_CXX_FLAGS
- "${CMAKE_CXX_FLAGS} ${CMAKE_IMLIB2_CXX_FLAGS}" )
-diff --git a/src/x.hpp b/src/x.hpp
-index 2478414..f35e722 100644
---- a/src/x.hpp
-+++ b/src/x.hpp
-@@ -26,7 +26,6 @@
- #include <X11/Xlib.h>
- #include <X11/cursorfont.h>
- #include <X11/extensions/shape.h>
--#include <X11/extensions/Xrandr.h>
-
- #include <stdlib.h>
- #include <cstring>
-@@ -97,7 +96,6 @@ public:
- std::vector<bool> m_mouse;
- bool mouseDown( unsigned int button );
- bool m_keypressed;
-- XRRScreenResources* m_res;
- private:
- slop::CursorType m_currentCursor;
- bool m_good;