summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/spnavcfg/spnavcfg-0.3.ebuild')
-rw-r--r--x11-misc/spnavcfg/spnavcfg-0.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/spnavcfg/spnavcfg-0.3.ebuild b/x11-misc/spnavcfg/spnavcfg-0.3.ebuild
new file mode 100644
index 000000000000..62c0ff4be0eb
--- /dev/null
+++ b/x11-misc/spnavcfg/spnavcfg-0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GTK-based GUI to configure a space navigator device"
+HOMEPAGE="http://spacenav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/spacenav/spacenavd%20config%20gui/${PN}%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-misc/spacenavd[X]"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-custom-flags.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "Make failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ dodoc README || die
+}