summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sxhkd/sxhkd-0.6.0.ebuild')
-rw-r--r--x11-misc/sxhkd/sxhkd-0.6.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/sxhkd/sxhkd-0.6.0.ebuild b/x11-misc/sxhkd/sxhkd-0.6.0.ebuild
new file mode 100644
index 000000000000..72d597e89864
--- /dev/null
+++ b/x11-misc/sxhkd/sxhkd-0.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Simple X hotkey daemon"
+HOMEPAGE="https://github.com/baskerville/sxhkd/"
+SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libxcb
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}
+ x11-libs/xcb-util"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ systemd_dounit contrib/systemd/${PN}.service
+}