summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xflux/xflux-20130927.ebuild')
-rw-r--r--x11-misc/xflux/xflux-20130927.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/xflux/xflux-20130927.ebuild b/x11-misc/xflux/xflux-20130927.ebuild
new file mode 100644
index 000000000000..4a83ec1eecd4
--- /dev/null
+++ b/x11-misc/xflux/xflux-20130927.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Makes the color of your computer's display adapt to the time of the day"
+HOMEPAGE="https://justgetflux.com/"
+SRC_URI="amd64? ( https://justgetflux.com/linux/${PN}64.tgz -> ${PN}64-${PV}.tar.gz )
+ x86? ( https://justgetflux.com/linux/${PN}-pre.tgz -> ${P}.tar.gz )"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="f.lux"
+SLOT="0"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="usr/bin/xflux"
+
+src_install() {
+ # Install binary
+ dobin xflux
+}