summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xkeycaps')
-rw-r--r--x11-misc/xkeycaps/Manifest1
-rw-r--r--x11-misc/xkeycaps/files/xkeycaps-2.47-Imakefile.patch22
-rw-r--r--x11-misc/xkeycaps/files/xkeycaps-2.47-man.patch12
-rw-r--r--x11-misc/xkeycaps/metadata.xml5
-rw-r--r--x11-misc/xkeycaps/xkeycaps-2.47-r1.ebuild46
5 files changed, 86 insertions, 0 deletions
diff --git a/x11-misc/xkeycaps/Manifest b/x11-misc/xkeycaps/Manifest
new file mode 100644
index 000000000000..0b2fa2ccad8b
--- /dev/null
+++ b/x11-misc/xkeycaps/Manifest
@@ -0,0 +1 @@
+DIST xkeycaps_2.47.orig.tar.gz 351418 SHA256 efd92e6179ec4506cbb08db11091185f3bd1567eecb2291f91f70980e175d8f4
diff --git a/x11-misc/xkeycaps/files/xkeycaps-2.47-Imakefile.patch b/x11-misc/xkeycaps/files/xkeycaps-2.47-Imakefile.patch
new file mode 100644
index 000000000000..42f7ab6e344d
--- /dev/null
+++ b/x11-misc/xkeycaps/files/xkeycaps-2.47-Imakefile.patch
@@ -0,0 +1,22 @@
+diff -ur xkeycaps-2.47.orig/Imakefile xkeycaps-2.47/Imakefile
+--- xkeycaps-2.47.orig/Imakefile 2005-02-23 00:33:15.000000000 +0200
++++ xkeycaps-2.47/Imakefile 2008-12-07 22:55:24.000000000 +0200
+@@ -1,5 +1,5 @@
+-/**/# Imakefile for xkeycaps;
+-/**/# Copyright (c) 1991, 1992, 1993, 1994, 1995, 1999 Jamie Zawinski.
++/* Imakefile for xkeycaps;
++ Copyright (c) 1991, 1992, 1993, 1994, 1995, 1999 Jamie Zawinski. */
+
+ /*
+ * To specify a different default keyboard (for when the vendor display
+@@ -353,8 +353,8 @@
+ TAR = tar
+ COMPRESS = compress
+ COMPRESS_EXT = Z
+-/**/# COMPRESS = gzip --verbose --best
+-/**/# COMPRESS_EXT = gz
++/* COMPRESS = gzip --verbose --best */
++/* COMPRESS_EXT = gz */
+
+ ComplexProgramTarget(xkeycaps)
+
diff --git a/x11-misc/xkeycaps/files/xkeycaps-2.47-man.patch b/x11-misc/xkeycaps/files/xkeycaps-2.47-man.patch
new file mode 100644
index 000000000000..f68629ef3eaf
--- /dev/null
+++ b/x11-misc/xkeycaps/files/xkeycaps-2.47-man.patch
@@ -0,0 +1,12 @@
+diff -ur xkeycaps-2.47.orig/xkeycaps.man xkeycaps-2.47/xkeycaps.man
+--- xkeycaps-2.47.orig/xkeycaps.man 2006-01-02 02:22:17.000000000 +0200
++++ xkeycaps-2.47/xkeycaps.man 2008-12-07 22:51:38.000000000 +0200
+@@ -267,7 +267,7 @@
+ the physical keys: it is immutable (unless you repaint your keyboard...)
+ .TP 10
+ .B \fIChord\fP
+-This term refers to a set of two or more keys held down simultaniously (by
++This term refers to a set of two or more keys held down simultaneously (by
+ analogy with piano keyboards.) All but one of the keys will generally be
+ Modifier Keys. Sometimes \fIConstellation\fP is used to mean the same thing.
+ .TP 10
diff --git a/x11-misc/xkeycaps/metadata.xml b/x11-misc/xkeycaps/metadata.xml
new file mode 100644
index 000000000000..731225048652
--- /dev/null
+++ b/x11-misc/xkeycaps/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xkeycaps/xkeycaps-2.47-r1.ebuild b/x11-misc/xkeycaps/xkeycaps-2.47-r1.ebuild
new file mode 100644
index 000000000000..0da28d0189a0
--- /dev/null
+++ b/x11-misc/xkeycaps/xkeycaps-2.47-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GUI frontend to xmodmap"
+HOMEPAGE="http://packages.qa.debian.org/x/xkeycaps.html"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-misc/xbitmaps
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-misc/imake
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Imakefile.patch \
+ "${FILESDIR}"/${P}-man.patch
+}
+
+src_compile() {
+ xmkmf || die
+ sed -i -e "s,all:: xkeycaps.\$(MANSUFFIX).html,all:: ,g" \
+ Makefile || die
+ emake EXTRA_LDOPTIONS="${LDFLAGS}" CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die
+ newman ${PN}.man ${PN}.1 || die
+ dodoc README *.txt || die
+}