summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xnots/xnots-9999.ebuild')
-rw-r--r--x11-misc/xnots/xnots-9999.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/x11-misc/xnots/xnots-9999.ebuild b/x11-misc/xnots/xnots-9999.ebuild
index d30b43eb9dc2..4615827f4fb6 100644
--- a/x11-misc/xnots/xnots-9999.ebuild
+++ b/x11-misc/xnots/xnots-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit git-r3 toolchain-funcs
+inherit flag-o-matic git-r3 toolchain-funcs
DESCRIPTION="A desktop sticky note program for the unix geek"
HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
@@ -13,20 +13,26 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="vim-syntax"
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
- x11-libs/libXrender
x11-libs/libXrandr
- x11-libs/pango[X]"
+ x11-libs/libXrender
+ x11-libs/pango[X]
+"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
virtual/pkgconfig
- x11-proto/xextproto
+ x11-proto/randrproto
x11-proto/renderproto
- x11-proto/randrproto"
+ x11-proto/xextproto
+"
src_prepare() {
sed -i -e 's|LICENCE||g' Makefile || die
+
+ append-cflags -std=gnu89
}
src_compile() {