summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/zim')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.70_rc1.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index 3e45224e2c77..0775182089be 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -1,3 +1,4 @@
DIST zim-0.65.tar.gz 1899614 BLAKE2B e7989d91120f2ffe0668c996b5abd61cc1cb12b2a5acf9023dfd87819b4c8834bba09f2211c901512d9fe186eee7939e44a5f098c09ef65f1d28cc55eb97e9b7 SHA512 dee652087d3d986b80353e9087abe363392354f40db11f8819d0b3f3c6f133c08c66c651a92ed77c1656f1135998ac02622eca08ac2e28c8fb3149a724a0f7fb
DIST zim-0.68.tar.gz 2044224 BLAKE2B 5c53c3197bc5de90c38059e7323366ed5b7600ebf0b3575d81e618d972d0360f67660da4637f1e6f1459549b21525ed17183e9c2f57f8ab0b27236e36bda9666 SHA512 4ab7f2b55e37ae917a7faa0018a36cbad2534bb43146f47810479155009eb2ccbf4f8ab185d8b4cd3ba7e22a4e2fc5eb08c4bae0688186c13d31dfcab23b0048
DIST zim-0.69.tar.gz 2044631 BLAKE2B 447fa4fb2d11b1399668ec6b627e23150577b574afb1e5c33738cb690779f49adb2d60e0b01eb82d2cf0dfd4a430099c1ae4b52186b60a2564c501b93aa01822 SHA512 452b2119d63927765c3807dbbdfadea94be31ee7fd3eb9b8cf79e8699c57478ec9cd392299a6e1dc3690dbe520925cddf5fca4596db809a2cc296bb6669d12af
+DIST zim-0.70-rc1.tar.gz 2023540 BLAKE2B a0e0543127db3a13e049b7aa6dba17d80f7a2fc0b48d1ee721965013f28537290687a576b9e5b9a21ee61a40eb9dfa526b49c4879bb8096330bdeb9c0aaf73a9 SHA512 4567015f9dc5b327ffbf31ea878d5b61ed2b4157fe523c1ab5049fbb716430fb8d1ff485432b84d6e22c804acd5dadc93f93749950e7eec4980bc26b7803ddfa
diff --git a/x11-misc/zim/zim-0.70_rc1.ebuild b/x11-misc/zim/zim-0.70_rc1.ebuild
new file mode 100644
index 000000000000..514ad573f12b
--- /dev/null
+++ b/x11-misc/zim/zim-0.70_rc1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+inherit xdg-utils distutils-r1 gnome2-utils virtualx
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="http://zim-wiki.org/"
+SRC_URI="${HOMEPAGE}/downloads/${P/_/-}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-vcs/bzr
+ dev-vcs/git
+ dev-vcs/mercurial
+ )
+"
+DOCS=( CHANGELOG.txt README.txt HACKING )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+S=${WORKDIR}/${P/_/-}
+
+python_prepare_all() {
+ sed -i -e "s/'USER'/'LOGNAME'/g" zim/__init__.py zim/fs.py || die
+
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ virtx ${PYTHON} test.py
+}
+
+python_install() {
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Please install these packages for additional functionality"
+ elog " dev-lang/R"
+ elog " dev-python/gtkspell-python"
+ elog " dev-vcs/bzr"
+ elog " media-gfx/graphviz"
+ elog " media-gfx/imagemagick"
+ elog " media-gfx/scrot"
+ elog " media-sound/lilypond"
+ elog " sci-visualization/gnuplot"
+ elog " virtual/latex-base app-text/dvipng"
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}