summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/gromit/files/gromit-20041213-build.patch2
-rw-r--r--x11-misc/gromit/gromit-20041213-r1.ebuild10
2 files changed, 8 insertions, 4 deletions
diff --git a/x11-misc/gromit/files/gromit-20041213-build.patch b/x11-misc/gromit/files/gromit-20041213-build.patch
index f61a13bcccd6..b539aa9e6dca 100644
--- a/x11-misc/gromit/files/gromit-20041213-build.patch
+++ b/x11-misc/gromit/files/gromit-20041213-build.patch
@@ -16,4 +16,4 @@ Fix underlinking for bug #369453.
gromit: gromit.c Makefile
- gcc -DG_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DPANGO_DISABLE_DEPRECATED -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall `pkg-config --libs --cflags gtk+-2.0`
-+ $(CC) -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall $(CFLAGS) $(LDFLAGS) `pkg-config --libs --cflags gtk+-2.0` -lX11 -lm
++ $(CC) -DGDK_MULTIHEAD_SAFE -DGTK_MULTIHEAD_SAFE -o gromit gromit.c -Wall $(CFLAGS) $(LDFLAGS) `${PKG_CONFIG} --libs --cflags gtk+-2.0` -lX11 -lm
diff --git a/x11-misc/gromit/gromit-20041213-r1.ebuild b/x11-misc/gromit/gromit-20041213-r1.ebuild
index e14be1452ea6..83184db01362 100644
--- a/x11-misc/gromit/gromit-20041213-r1.ebuild
+++ b/x11-misc/gromit/gromit-20041213-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="GRaphics Over MIscellaneous Things, a presentation helper"
@@ -11,16 +12,19 @@ SRC_URI="http://www.home.unix-ag.org/simon/gromit/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
-IUSE=""
RDEPEND="x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig
"
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+)
src_compile() {
+ tc-export PKG_CONFIG
+
emake CC=$(tc-getCC)
}