summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xmonad-log-applet/Manifest1
-rw-r--r--x11-misc/xmonad-log-applet/files/xmonad.hs60
-rw-r--r--x11-misc/xmonad-log-applet/metadata.xml16
-rw-r--r--x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild47
4 files changed, 0 insertions, 124 deletions
diff --git a/x11-misc/xmonad-log-applet/Manifest b/x11-misc/xmonad-log-applet/Manifest
deleted file mode 100644
index 44bdd2c505d8..000000000000
--- a/x11-misc/xmonad-log-applet/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xmonad-log-applet-2.0.0.tar.gz 82881 BLAKE2B a059158558cc2fcb150e90cbd055cf50367dbed464c46891b6c63d49d2b5e2974ea3fc859afe8f1115af78fae60e639bde0aec37af8be693720eca80905712b8 SHA512 1885ac97569d909ab1c6af99d9b271d0f782de905dfe035df27524f428d09cefa20a468103477132656dea8945faf886270fd70a49e5a08be538e04f3f05baca
diff --git a/x11-misc/xmonad-log-applet/files/xmonad.hs b/x11-misc/xmonad-log-applet/files/xmonad.hs
deleted file mode 100644
index 54b0025a97c4..000000000000
--- a/x11-misc/xmonad-log-applet/files/xmonad.hs
+++ /dev/null
@@ -1,60 +0,0 @@
-import XMonad
-import XMonad.Config.Gnome
-import XMonad.Hooks.DynamicLog
-
-import Control.OldException
-
-import DBus
-import DBus.Connection
-import DBus.Message
-
-main :: IO ()
-main = withConnection Session $ \dbus -> do
- getWellKnownName dbus
- xmonad $ gnomeConfig
- { logHook = dynamicLogWithPP (prettyPrinter dbus)
- }
-
-prettyPrinter :: Connection -> PP
-prettyPrinter dbus = defaultPP
- { ppOutput = dbusOutput dbus
- , ppTitle = pangoSanitize
- , ppCurrent = pangoColor "green" . wrap "[" "]" . pangoSanitize
- , ppVisible = pangoColor "yellow" . wrap "(" ")" . pangoSanitize
- , ppHidden = const ""
- , ppUrgent = pangoColor "red"
- , ppLayout = const ""
- , ppSep = " "
- }
-
-getWellKnownName :: Connection -> IO ()
-getWellKnownName dbus = tryGetName `catchDyn` (\(DBus.Error _ _) -> getWellKnownName dbus)
- where
- tryGetName = do
- namereq <- newMethodCall serviceDBus pathDBus interfaceDBus "RequestName"
- addArgs namereq [String "org.xmonad.Log", Word32 5]
- sendWithReplyAndBlock dbus namereq 0
- return ()
-
-dbusOutput :: Connection -> String -> IO ()
-dbusOutput dbus str = do
- msg <- newSignal "/org/xmonad/Log" "org.xmonad.Log" "Update"
- addArgs msg [String ("<b>" ++ str ++ "</b>")]
- -- If the send fails, ignore it.
- send dbus msg 0 `catchDyn` (\(DBus.Error _ _) -> return 0)
- return ()
-
-pangoColor :: String -> String -> String
-pangoColor fg = wrap left right
- where
- left = "<span foreground=\"" ++ fg ++ "\">"
- right = "</span>"
-
-pangoSanitize :: String -> String
-pangoSanitize = foldr sanitize ""
- where
- sanitize '>' xs = "&gt;" ++ xs
- sanitize '<' xs = "&lt;" ++ xs
- sanitize '\"' xs = "&quot;" ++ xs
- sanitize '&' xs = "&amp;" ++ xs
- sanitize x xs = x:xs
diff --git a/x11-misc/xmonad-log-applet/metadata.xml b/x11-misc/xmonad-log-applet/metadata.xml
deleted file mode 100644
index e8a655590796..000000000000
--- a/x11-misc/xmonad-log-applet/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- </maintainer>
- <maintainer type="person">
- <email>flo@geekplace.eu</email>
- </maintainer>
- <longdescription>
- xmonad-log-applet is for Xmonad users who find the GNOME, MATE, or Xfce panel useful. The applet will show the active workspaces, the title of the selected window or whatever information you send it from your xmonad.hs.
- </longdescription>
- <upstream>
- <remote-id type="github">alexkay/xmonad-log-applet</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild b/x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild
deleted file mode 100644
index 9038beb0ce04..000000000000
--- a/x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools gnome2
-
-DESCRIPTION="Gnome and XFCE applet for displaying XMonad log"
-HOMEPAGE="https://github.com/alexkay/xmonad-log-applet"
-SRC_URI="https://github.com/downloads/alexkay/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT="mirror"
-
-RDEPEND="
- sys-apps/dbus
- xfce-base/xfce4-panel
- dev-libs/dbus-glib
- dev-libs/glib:2
- dev-haskell/dbus
- x11-libs/gtk+:3
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure --sysconfdir=/etc --with-panel=xfce4
-}
-
-src_install() {
- gnome2_src_install
- dodoc AUTHORS.md README.md
- dodoc "${FILESDIR}"/xmonad.hs
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- elog "Remember to update your xmonad.hs accordingly"
- elog "a sample xmonad.hs is provided in /usr/share/doc/${PF}"
-}