summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild')
-rw-r--r--x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
index db88433d0fe0..208a9d80056f 100644
--- a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
+++ b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="A mixer control plugin for gkrellm"
@@ -13,22 +14,20 @@ SLOT="2"
KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
IUSE="alsa"
-DEPEND="alsa? ( media-libs/alsa-lib )"
-RDEPEND="${DEPEND}
- app-admin/gkrellm[X]
-"
-
-S="${WORKDIR}/${PN}"
-
-PLUGIN_SO="volume.so"
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${PN}
PATCHES=(
"${FILESDIR}/${P}-reenable.patch"
"${FILESDIR}/${P}-makefile.patch"
)
+PLUGIN_SO=( volume$(get_modname) )
+
src_compile() {
- local myconf=""
- use alsa && myconf="${myconf} enable_alsa=1"
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" "${myconf}"
+ use alsa && local myconf="enable_alsa=1"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}
}