summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild')
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild
new file mode 100644
index 000000000000..69348861bc84
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-1.0.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit gkrellm-plugin eutils
+
+IUSE="nls"
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times"
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~sparc x86"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+PLUGIN_SO=src20/gkrellsun.so
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-reenable.patch"
+ epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ use nls && myconf="$myconf enable_nls=1"
+ emake ${myconf}
+}