summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch')
-rw-r--r--x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch
new file mode 100644
index 000000000000..6aa6ffca3c52
--- /dev/null
+++ b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2015-02-07 03:23:05.000000000 +0000
++++ b/Makefile 2016-04-28 09:53:59.915565380 +0000
+@@ -2,6 +2,7 @@
+
+ SECRETFLAGS = `pkg-config --libs --cflags libsecret-1`
+ PURPLEFLAGS = `pkg-config --cflags purple`
++PLUGINDIR = `pkg-config --variable=plugindir purple`
+ VERSION = $(shell cat VERSION)
+ ifeq ($(strip $(VERSION)),)
+ VERSION = `git describe --tags`
+@@ -18,8 +19,8 @@
+ ${CC} ${CFLAGS} ${LDFLAGS} -Wall -I. -g -O2 ${TARGET}.c -o ${TARGET}.so -shared -fPIC -DPIC -ggdb ${PURPLEFLAGS} ${SECRETFLAGS} -DVERSION=\"${VERSION}\"
+
+ install: ${TARGET}.so
+- mkdir -p ${DESTDIR}/usr/lib/purple-2/
+- cp ${TARGET}.so ${DESTDIR}/usr/lib/purple-2/
++ mkdir -p ${DESTDIR}/$(PLUGINDIR)/
++ cp ${TARGET}.so ${DESTDIR}/$(PLUGINDIR)/
+
+ install_local: ${TARGET}.so
+ mkdir -p ~/.purple/plugins