summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild')
-rw-r--r--x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
index 66f4ca8ec602..7fdcae9bcf96 100644
--- a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
+++ b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
MY_PN="wmspaceweather"
MY_PV_ORIG="${PV/_p*}"
@@ -33,16 +33,17 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${MY_P_ORIG/_/-}/${PN}"
-src_unpack() {
- unpack ${MY_P_ORIG}.tar.gz
- epatch "${DISTDIR}"/${MY_P_PATCH}.gz
- epatch "${FILESDIR}"/${P}-gcc-10.patch
+src_prepare() {
+ default
+
+ cd .. || die
+
+ eapply "${WORKDIR}"/${MY_P_PATCH}
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
# need to apply patches from Debian first, do NOT change the order
cd "${S}" || die
- mv ../debian/patches "${WORKDIR}"/patch || die
- EPATCH_SUFFIX="dpatch" EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying Debian patches ..." epatch
+ eapply -p2 ../debian/patches/*.dpatch
eapply "${FILESDIR}"/${P}-gentoo.patch
eapply "${FILESDIR}"/${P}-getkp.patch
}