summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild')
-rw-r--r--x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild b/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
new file mode 100644
index 000000000000..cddbcd6bd97d
--- /dev/null
+++ b/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WindowMaker CPU and Memory Usage Monitor Dock App"
+HOMEPAGE="https://www.geocities.ws/neofpo/wmcms.html"
+SRC_URI="https://www.geocities.ws/neofpo/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=x11-libs/libdockapp-0.7-r1:="
+
+PATCHES=(
+ "${FILESDIR}"/${P}-s4t4n.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ # Respect LDFLAGS, see bug #335031
+ sed -e 's/ -o wmcms/ ${LDFLAGS} -o wmcms/' -i Makefile || die
+
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin wmcms
+}