summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-proto/xcb-proto/xcb-proto-1.11.ebuild')
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.11.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/x11-proto/xcb-proto/xcb-proto-1.11.ebuild b/x11-proto/xcb-proto/xcb-proto-1.11.ebuild
deleted file mode 100644
index dc390555ad72..000000000000
--- a/x11-proto/xcb-proto/xcb-proto-1.11.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-XORG_MULTILIB=yes
-
-inherit python-r1 xorg-2
-
-DESCRIPTION="X C-language Bindings protocol headers"
-HOMEPAGE="https://xcb.freedesktop.org/"
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
-[[ ${PV} != 9999* ]] && \
- SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
-
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- dev-libs/libxml2"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- python_setup
- xorg-2_src_configure
-}
-
-multilib_src_configure() {
- autotools-utils_src_configure
-
- if multilib_is_native_abi; then
- python_foreach_impl autotools-utils_src_configure
- fi
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi; then
- python_foreach_impl autotools-utils_src_compile -C xcbgen \
- top_builddir="${BUILD_DIR}"
- fi
-}
-
-src_install() {
- xorg-2_src_install
-
- # pkg-config file hardcodes python sitedir, bug 486512
- sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
- "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi; then
- python_foreach_impl autotools-utils_src_install -C xcbgen \
- top_builddir="${BUILD_DIR}"
- fi
-}