summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.14.1.ebuild')
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.14.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.14.1.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.14.1.ebuild
new file mode 100644
index 000000000000..ad608cb46da4
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.14.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="http://www.gnome.org/ http://people.freedesktop.org/~jimmac/icons/#git"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="|| ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-Sampling-Plus-1.0 )"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-themes/hicolor-icon-theme-0.10
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/librsvg:2
+ !<x11-themes/gnome-themes-standard-3.14
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Make it the default cursor theme
+ dosym Adwaita /usr/share/cursors/xorg-x11/default
+}