summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild')
-rw-r--r--x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild b/x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild
new file mode 100644
index 000000000000..b338c949873f
--- /dev/null
+++ b/x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P="5507-Golden-XCursors-3D-${PV}"
+DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=5507"
+SRC_URI="http://www.kde-look.org/content/files/$MY_P.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dodir /usr/share/cursors/xorg-x11/Gold/cursors/
+ cp -R "${WORKDIR}"/${MY_P:5}/Gold/cursors "${D}"/usr/share/cursors/xorg-x11/Gold/ || die
+ dodoc "${WORKDIR}"/${MY_P:5}/README
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line:"
+ einfo "Xcursor.theme: Gold"
+ einfo ""
+ einfo "You can change the size by adding a line like:"
+ einfo "Xcursor.size: 48"
+ einfo ""
+ einfo "Also, to globally use this set of mouse cursors edit the file:"
+ einfo " /usr/share/cursors/xorg-x11/default/index.theme"
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]"
+ einfo "to"
+ einfo " Inherits=Gold"
+ einfo ""
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file."
+ einfo ""
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn ""
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}