summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/lxqt-themes/lxqt-themes-0.17.0.ebuild')
-rw-r--r--x11-themes/lxqt-themes/lxqt-themes-0.17.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-themes/lxqt-themes/lxqt-themes-0.17.0.ebuild b/x11-themes/lxqt-themes/lxqt-themes-0.17.0.ebuild
new file mode 100644
index 000000000000..e9df8dd6dc08
--- /dev/null
+++ b/x11-themes/lxqt-themes/lxqt-themes-0.17.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt Themes"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.9.0"