summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild')
-rw-r--r--x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild
new file mode 100644
index 000000000000..d8144746a137
--- /dev/null
+++ b/x11-themes/ubuntu-wallpapers/ubuntu-wallpapers-19.04.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Ubuntu wallpapers"
+HOMEPAGE="https://launchpad.net/ubuntu/+source/ubuntu-wallpapers"
+MY_P="${PN}_${PV}"
+SRC_URI="mirror://ubuntu/pool/main/u/${PN}/${MY_P}.orig.tar.gz"
+
+# Review copying file for updates
+LICENSE="CC-BY-SA-3.0 CC-BY-SA-2.0 CC-BY-2.0 CC-BY-SA-4.0"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+SLOT="0"
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ insinto /usr/share/backgrounds
+ doins *.jpg *.png
+
+ insinto /usr/share/backgrounds/contest
+ doins contest/*.xml
+
+ for i in *.xml.in; do
+ insinto /usr/share/gnome-background-properties
+ newins ${i} ${i/.in/}
+ done
+
+ einstalldocs
+}