summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/vertex-theme/Manifest1
-rw-r--r--x11-themes/vertex-theme/vertex-theme-20170128-r1.ebuild47
-rw-r--r--x11-themes/vertex-theme/vertex-theme-20170128.ebuild47
3 files changed, 95 insertions, 0 deletions
diff --git a/x11-themes/vertex-theme/Manifest b/x11-themes/vertex-theme/Manifest
index 58b77e405b75..95eea0a7c8f3 100644
--- a/x11-themes/vertex-theme/Manifest
+++ b/x11-themes/vertex-theme/Manifest
@@ -1 +1,2 @@
DIST vertex-theme-20160329.tar.gz 3770162 SHA256 c075c9fc059a5b2e30e65242a000083b5f8621a5cdfebb7ac61c31e33c6cbe85 SHA512 bd63e9c5e6eadb7ea9a8a96c1131e3d55a2a715a399a7b5035fec1f6c2b89ee534e46b6e38ec0272d4cbcb05839b40d4a3fa0cabd4b8276a18c6fb059afe1c7d WHIRLPOOL fb62a45dd043363057f24cfe90691c5bbba5edbf16d9c8eabd56c519bdf9bfe884d9baa814cc5981687ad25e22c2d9f7b7fb2dd0a375499630744ca5a75baf3b
+DIST vertex-theme-20170128.tar.gz 3776773 SHA256 1540657ff247bcdb9c49a740e4ddf305aecd4f3bebc93ca566fe74d319b7a620 SHA512 293b24d11424e2ee0e2223bca8423800b1f077d4f902d1ca3b2a28f46ac2cdb4ec3e50cd350d996c15be567112652ae9b43827d6615482fdbb30659e905a1f82 WHIRLPOOL ae46a914948e1a4ef779c4caa18c9bdab4626e3570a66b4b3918682d25d7f2d71d4b7e6b27043d4c1d1268c5b5950acf79db9e19b8811a92c0bf77563e66b4a8
diff --git a/x11-themes/vertex-theme/vertex-theme-20170128-r1.ebuild b/x11-themes/vertex-theme/vertex-theme-20170128-r1.ebuild
new file mode 100644
index 000000000000..64f776478cef
--- /dev/null
+++ b/x11-themes/vertex-theme/vertex-theme-20170128-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Vertex theme for GTK+ based desktops"
+HOMEPAGE="https://github.com/horst3180/vertex-theme"
+SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cinnamon gnome-shell mate xfce"
+
+RDEPEND="
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ cinnamon? ( >=x11-libs/gtk+-3.22:3 )
+ gnome-shell? ( >=x11-libs/gtk+-3.22:3 )
+"
+DEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Do not let configure try to figure out gtk+:3 version installed
+ # See also https://github.com/horst3180/arc-theme/issues/436 and 484
+ "${FILESDIR}"/configure-gtk3-version.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-unity \
+ --enable-gtk2 \
+ --enable-gtk3 \
+ --with-gnome=3.22 \
+ $(use_enable cinnamon) \
+ $(use_enable gnome-shell) \
+ $(use_enable mate metacity) \
+ $(use_enable xfce xfwm)
+}
diff --git a/x11-themes/vertex-theme/vertex-theme-20170128.ebuild b/x11-themes/vertex-theme/vertex-theme-20170128.ebuild
new file mode 100644
index 000000000000..79e5c37c0cba
--- /dev/null
+++ b/x11-themes/vertex-theme/vertex-theme-20170128.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Vertex theme for GTK+ based desktops"
+HOMEPAGE="https://github.com/horst3180/vertex-theme"
+SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cinnamon gnome-shell mate xfce"
+
+RDEPEND="
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ cinnamon? ( >=x11-libs/gtk+-3.20:3 )
+ gnome-shell? ( >=x11-libs/gtk+-3.20:3 )
+"
+DEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Do not let configure try to figure out gtk+:3 version installed
+ # See also https://github.com/horst3180/arc-theme/issues/436 and 484
+ "${FILESDIR}"/configure-gtk3-version.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-unity \
+ --enable-gtk2 \
+ --enable-gtk3 \
+ --with-gnome=3.20 \
+ $(use_enable cinnamon) \
+ $(use_enable gnome-shell) \
+ $(use_enable mate metacity) \
+ $(use_enable xfce xfwm)
+}