summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/cwm/cwm-5.1.ebuild')
-rw-r--r--x11-wm/cwm/cwm-5.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/cwm/cwm-5.1.ebuild b/x11-wm/cwm/cwm-5.1.ebuild
new file mode 100644
index 000000000000..ef17e986d3c5
--- /dev/null
+++ b/x11-wm/cwm/cwm-5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ http://github.com/chneukirchen/cwm"
+SRC_URI="http://chneukirchen.org/releases/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/bison"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.2_p20111229-Makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}