summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/cwm/cwm-9999.ebuild')
-rw-r--r--x11-wm/cwm/cwm-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/cwm/cwm-9999.ebuild b/x11-wm/cwm/cwm-9999.ebuild
new file mode 100644
index 000000000000..21b960b1c98e
--- /dev/null
+++ b/x11-wm/cwm/cwm-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs git-2
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ http://github.com/chneukirchen/cwm"
+EGIT_BRANCH=linux
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE="vanilla"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/bison"
+
+pkg_setup() {
+ if use vanilla ; then
+ EGIT_REPO_URI="https://github.com/chneukirchen/cwm.git"
+ else
+ EGIT_REPO_URI="https://github.com/xmw/cwm.git"
+ fi
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}