summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/herbstluftwm/herbstluftwm-9999.ebuild')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index 0cea06f49ee7..9fe9d04ef469 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -7,11 +7,11 @@ inherit toolchain-funcs bash-completion-r1
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm.git"
- EXTRA_DEPEND="app-text/asciidoc"
+ BDEPEND="app-text/asciidoc"
else
SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
- EXTRA_DEPEND=""
+ BDEPEND=""
fi
DESCRIPTION="A manual tiling window manager for X"
@@ -21,16 +21,14 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="examples xinerama zsh-completion"
-CDEPEND=">=dev-libs/glib-2.24:2
+DEPEND=">=dev-libs/glib-2.24:2
x11-libs/libX11
x11-libs/libXext
xinerama? ( x11-libs/libXinerama )"
-RDEPEND="${CDEPEND}
+RDEPEND="${DEPEND}
app-shells/bash
zsh-completion? ( app-shells/zsh )"
-DEPEND="${CDEPEND}
- ${EXTRA_DEPEND}
- virtual/pkgconfig"
+BDEPEND+=" virtual/pkgconfig"
src_compile() {
tc-export CC LD CXX