summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-0.6.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 4867cf5686b1..37fd92097833 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1 +1,2 @@
DIST garcon-0.6.1.tar.bz2 511415 BLAKE2B 03c9076d8507737ed64b48597ff53c4cb3ae9beafd14b28d4d61fc29fa007f5ac4757f96ba0dc56c8b069a4eebd5d38202862856f96a1b08474de2aa93d518ca SHA512 36c5b1ba3c91e613853cd5e986176c8cbd2a509fafde1b302334deda872b7f7073fd06ba341220b030d8d5728346b7339368190b225203f33c023dd96f3ed1a3
+DIST garcon-0.6.2.tar.bz2 539745 BLAKE2B 1bcbb136cd525f1280f6539ea447b4b84f935297f6bd4391407e31925cf873fdd0cfbeb70dba5ce882e4620f1ce7b89d51c9c26232db88b1202f5a0fca3f6175 SHA512 7a96c33b47302fa989862098bc5b8ed64515a60e19a4b8dbb049398cf847d64584f93f85b1f6e1327653b22f0b44a805b737258bbc9ac69197639ef7f13f20b1
diff --git a/xfce-base/garcon/garcon-0.6.2.ebuild b/xfce-base/garcon/garcon-0.6.2.ebuild
new file mode 100644
index 000000000000..fa58d50f7a3f
--- /dev/null
+++ b/xfce-base/garcon/garcon-0.6.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="https://docs.xfce.org/xfce/exo/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+gtk2"
+
+RDEPEND=">=dev-libs/glib-2.30:=
+ gtk2? ( >=x11-libs/gtk+-2.24:2= )
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README STATUS TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable gtk2)
+ $(use_enable gtk2 libxfce4ui)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}