summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.99.ebuild')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.99.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.99.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.99.ebuild
new file mode 100644
index 000000000000..aaa03669eab1
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.99.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+src_prepare() {
+ # substitute default bugtracker
+ sed -i -e '/bugs/s:bugs\.debian:bugs.gentoo:' src/smartbookmark.c || die
+ xfconf_src_prepare
+}