aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leise <marco.leise@gmx.de>2020-04-18 18:45:20 +0200
committerMarco Leise <marco.leise@gmx.de>2020-04-18 18:52:32 +0200
commite033dcbf92d157ee53d006163e23a125f022bed3 (patch)
tree3bcd2487029233ba508f988f2ad9ca08928c016d /dev-util
parentonedrive-2.4.0 (diff)
downloaddlang-e033dcbf92d157ee53d006163e23a125f022bed3.tar.gz
dlang-e033dcbf92d157ee53d006163e23a125f022bed3.tar.bz2
dlang-e033dcbf92d157ee53d006163e23a125f022bed3.zip
added support for gcc-9.3.0
Signed-off-by: Marco Leise <marco.leise@gmx.de>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gdmd/gdmd-9.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/gdmd/gdmd-9.3.0.ebuild b/dev-util/gdmd/gdmd-9.3.0.ebuild
new file mode 100644
index 0000000..e86456b
--- /dev/null
+++ b/dev-util/gdmd/gdmd-9.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrapper script for gdc that emulates the dmd command"
+HOMEPAGE="http://www.gdcproject.org/"
+LICENSE="GPL-3+"
+
+SLOT="${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+RDEPEND="=sys-devel/gcc-${PV}*[d]"
+RELEASE="0.1.0"
+SRC_URI="https://codeload.github.com/D-Programming-GDC/gdmd/tar.gz/script-${RELEASE} -> gdmd-${RELEASE}.tar.gz"
+PATCHES="${FILESDIR}/${PN}-no-dmd-conf.patch"
+S="${WORKDIR}/gdmd-script-${RELEASE}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local binPath="usr/${CHOST}/gcc-bin/${PV}"
+ exeinto "${binPath}"
+ newexe dmd-script "${CHOST}-gdmd"
+ ln -f "${D}/${binPath}/${CHOST}-gdmd" "${D}/${binPath}/gdmd" || die "Could not create 'gdmd' hardlink"
+}