summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-18 11:51:21 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-06-18 11:51:21 -0400
commitb22499209e2fd8510225056e84305b6aaedb3355 (patch)
tree3b96ac14bf68800027cc682d405c4a261d162e1b
parentFixed patches, and udevil ebuild and removed 0.2.7... (diff)
downloadArmageddon-b22499209e2fd8510225056e84305b6aaedb3355.tar.gz
Armageddon-b22499209e2fd8510225056e84305b6aaedb3355.tar.bz2
Armageddon-b22499209e2fd8510225056e84305b6aaedb3355.zip
Merging udevil-0.2.8 with the in the tree...
Removing udevil-0.2.7 from the overlay...
-rw-r--r--sys-apps/udevil/files/udevil-0.2.7-flags.patch49
-rw-r--r--sys-apps/udevil/udevil-0.2.7.ebuild54
-rw-r--r--sys-apps/udevil/udevil-0.2.8.ebuild31
3 files changed, 15 insertions, 119 deletions
diff --git a/sys-apps/udevil/files/udevil-0.2.7-flags.patch b/sys-apps/udevil/files/udevil-0.2.7-flags.patch
deleted file mode 100644
index 50abdcd..0000000
--- a/sys-apps/udevil/files/udevil-0.2.7-flags.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From: Elijah El Lazkani <ThyArmageddon+Gentoo@Gmail.com>
-Date: Wed Jun 13 22:45:09 UTC 2012
-Subject: Removing explicit LDFLAGS and CPPFLAGS
-
---- configure.ac
-+++ configure.ac
-@@ -16,42 +16,6 @@
- AC_DEFINE_UNQUOTED(UDEVIL_VERSION, "$VERSION", [udevil version])
-
-
--dnl linker optimizations
--AC_MSG_CHECKING([whether $LD accepts --as-needed])
--case `$LD --as-needed -v 2>&1 </dev/null` in
--*GNU* | *'with BFD'*)
-- LDFLAGS="$LDFLAGS -Wl,--as-needed"
-- AC_MSG_RESULT([yes])
-- ;;
--*)
-- AC_MSG_RESULT([no])
-- ;;
--esac
--AC_MSG_CHECKING([whether $LD accepts -O1])
--case `$LD -O1 -v 2>&1 </dev/null` in
--*GNU* | *'with BFD'*)
-- LDFLAGS="$LDFLAGS -Wl,-O1"
-- AC_MSG_RESULT([yes])
-- ;;
--*)
-- AC_MSG_RESULT([no])
-- ;;
--esac
--AC_MSG_CHECKING([whether $LD accepts -Bsymbolic-functions])
--case `$LD -Bsymbolic-functions -v 2>&1 </dev/null` in
--*GNU* | *'with BFD'*)
-- LDFLAGS="$LDFLAGS -Wl,-Bsymbolic-functions"
-- AC_MSG_RESULT([yes])
-- ;;
--*)
-- AC_MSG_RESULT([no])
-- ;;
--esac
--
--dnl advanced compiler tweaking
--CPPFLAGS="$CPPFLAGS -fstrict-aliasing -fmessage-length=0"
--
--
- # program paths
- AC_ARG_WITH(mount-prog,
- AC_HELP_STRING([--with-mount-prog=PATH], [Path to mount program (default: /bin/mount)]),
diff --git a/sys-apps/udevil/udevil-0.2.7.ebuild b/sys-apps/udevil/udevil-0.2.7.ebuild
deleted file mode 100644
index 5334f85..0000000
--- a/sys-apps/udevil/udevil-0.2.7.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit eutils autotools user
-
-DESCRIPTION="Linux program to mount and unmount removable devices without a password"
-HOMEPAGE="http://ignorantguru.github.com/udevil/"
-SRC_URI="https://github.com/IgnorantGuru/${PN}/raw/master/packages/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- >=app-shells/bash-4.0
- >=sys-fs/udev-143
- sys-libs/glibc
- virtual/acl"
-DEPEND="${RDEPEND}
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
-
-pkg_setup() {
- enewgroup plugdev
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-flags.patch"
- eautoreconf
-}
-
-src_configure() {
- econf --with-setfacl-prog=/bin/setfacl
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- doman man/udevil.1
- dodoc AUTHORS ChangeLog README
- fowners root:plugdev /usr/bin/udevil
- fperms 4754 /usr/bin/udevil
-}
-
-pkg_postinst() {
- echo
- elog "Please add your user to the plugdev group"
- elog "to be able to use ${PN} as a user"
- echo
-}
diff --git a/sys-apps/udevil/udevil-0.2.8.ebuild b/sys-apps/udevil/udevil-0.2.8.ebuild
index 4bff0c9..01400bb 100644
--- a/sys-apps/udevil/udevil-0.2.8.ebuild
+++ b/sys-apps/udevil/udevil-0.2.8.ebuild
@@ -1,24 +1,23 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/udevil/udevil-0.2.8.ebuild,v 1.2 2012/06/17 17:16:26 hasufell Exp $
EAPI=4
inherit eutils autotools user
-DESCRIPTION="Linux program to mount and unmount removable devices without a password"
+DESCRIPTION="mount and unmount removable devices without a password"
HOMEPAGE="http://ignorantguru.github.com/udevil/"
-SRC_URI="https://github.com/IgnorantGuru/${PN}/raw/master/packages/${PV}/${P}.tar.xz"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="
- >=app-shells/bash-4.0
+RDEPEND=">=app-shells/bash-4.0
+ sys-apps/util-linux
>=sys-fs/udev-143
- sys-libs/glibc
virtual/acl"
DEPEND="${RDEPEND}
dev-util/intltool
@@ -35,30 +34,30 @@ src_prepare() {
}
src_configure() {
- econf --with-setfacl-prog=/bin/setfacl
+ econf \
+ --with-setfacl-prog="$(type -P setfacl)"
}
src_install() {
default
- doman man/udevil.1
fowners root:plugdev /usr/bin/udevil
fperms 4754 /usr/bin/udevil
}
pkg_postinst() {
- echo
+ einfo
elog "Please add your user to the plugdev group"
elog "to be able to use ${PN} as a user"
elog
elog "Optional dependencies:"
- elog "gnome-extra/zenity (devmon popups)"
- elog "net-fs/cifs-utils (mounting samba shares)"
- elog "net-fs/curlftpfs (mounting ftp shares)"
- elog "net-fs/nfs-utils (mounting nfs shares)"
- elog "sys-fs/sshfs-fuse (mounting sftp shares)"
- elog "virtual/eject (eject via devmon)"
- einfo
+ elog " gnome-extra/zenity (devmon popups)"
+ elog " net-fs/cifs-utils (mounting samba shares)"
+ elog " net-fs/curlftpfs (mounting ftp shares)"
+ elog " net-fs/nfs-utils (mounting nfs shares)"
+ elog " sys-fs/sshfs-fuse (mounting sftp shares)"
+ elog " virtual/eject (eject via devmon)"
if ! has_version 'sys-fs/udisks' ; then
+ elog
elog "When using ${PN} without udisks, and without the udisks-daemon running,"
elog "you may need to enable kernel polling for device media changes to be detected."
elog "See http://ignorantguru.github.com/${PN}/#polling"